<!doctype html><!--[if (IE 8)&!(IEMobile)]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if (IE 9)&!(IEMobile)]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 9]><!--><html class="no-js" lang="en"><!--<![endif]--><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians</title><meta name="title" content="Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians"><meta name="description" content="The mother of a Nigerian Christian schoolgirl who has been kidnapped by Islamic radical group Boko Haram has said that she is proud of her daughter for not denouncing Jesus, while a classmate shared hopes that God might use her to turn her attackers to Christ."><meta name="Keywords" content="boko haram,nigerian schoolgirl,kidnapped schoolgirl,leah sharibu,jesus christ"><meta property="og:title" content="Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians"><meta property="og:description" content="The mother of a Nigerian Christian schoolgirl who has been kidnapped by Islamic radical group Boko Haram has said that she is proud of her daughter for not denouncing Jesus, while a classmate shared hopes that God might use her to turn her attackers to Christ."><meta property="og:image" content="https://data.christianpost.com/full/102869/chibok.jpg"><meta property="og:type" content="article"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@ChristianPost"><meta name="twitter:title" content="Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians"><meta name="twitter:description" content="The mother of a Nigerian Christian schoolgirl who has been kidnapped by Islamic radical group Boko Haram has said that she is proud of her daughter for not denouncing Jesus, while a classmate shared hopes that God might use her to turn her attackers to Christ."><meta name="twitter:image" content="https://data.christianpost.com/full/102869/chibok.jpg"><meta property="og:url" content="https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/"><meta name="news_keywords" content="boko haram,nigerian schoolgirl,kidnapped schoolgirl,leah sharibu,jesus christ"><meta name="HandheldFriendly" content="True"><meta name="MobileOptimized" content="320"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><!-- favicons --><link rel="apple-touch-icon" sizes="180x180" href="//g-4cf9.kxcdn.com/cp/img/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon-16x16.png" sizes="16x16"><link rel="manifest" href="//g-4cf9.kxcdn.com/cp/img/favicons/manifest.json"><link rel="mask-icon" href="//g-4cf9.kxcdn.com/cp/img/favicons/safari-pinned-tab.svg" color="#2577cf"><link rel="shortcut icon" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon.ico"><meta name="msapplication-config" content="//g-4cf9.kxcdn.com/cp/img/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><meta property="fb:app_id" content="1879686555693183"> <!-- publication page --> <link rel="canonical" href="https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/" /> <link rel="amphtml" href="https://www.christianpost.com/amp/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/"> <!-- publication page --> <!-- css --><link rel="stylesheet" href="//g-4cf9.kxcdn.com/cp/css/main.css"><script>-1!==location.search.indexOf("abspl=ZmJ2aXJhbA")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","ZmJ2aXJhbA","; path=/;"].join(""));-1!==location.search.indexOf("abspl=b3V0YnJhaW4")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","b3V0YnJhaW4","; path=/;"].join(""));-1!==location.search.indexOf("abspl=YmluZ2Fkcw")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","YmluZ2Fkcw","; path=/;"].join(""));!function(){var a=location.href;var p=function(){var i,t={},s=/=/.test(a),n=(s?a:location.search.substring(1)).split("&");for(p in n)i=n[p].split("="),t[i[0]]=i[1];return!a||s?t:t[a]}();p&&p.absid&&(document.cookie=["absid","=",p.absid,"; path=/;"].join(""));}();</script> <script>!function(){var a,b,c,d,e,f,g,h,i,j,k="cssc",l=new Date,m=new Date;return m.setDate(1),m.setMonth(m.getMonth()-1),a=k+l.getYear()+l.getMonth(),b=k+m.getYear()+m.getMonth(),c=function(a,b){var c=[a,"=",JSON.stringify(b),"; path=/;expires="+new Date(Date.now()+5184e6).toGMTString()].join("");document.cookie=c},d=function(a,b,c){var d=document.cookie.match(new RegExp(a+"=([^;]+)"));return d?(d=JSON.parse(d[1]),d||0):(d=document.cookie.match(new RegExp(b+"=([^;]+)")))?(d=JSON.parse(d[1]),Math.floor((d||0)/2)):(d=document.cookie.match(new RegExp(a+"=([^;]+)")),d&&(d=JSON.parse(d[1])),d||0)},e=function(a){var b;return b=a.indexOf("://")>-1?a.split("/")[2]:a.split("/")[0],b=b.split(":")[0]},f=d(a,b,k),g=function(){var a=0,b=36,c=(new Date).getHours(),d=(new Date).getDay();(c>19||c<7||Math.random()<.5&&12==c)&&(a=9999),0!=d&&6!=d||(a=9999),window.spSampleMarker=!(f>=a),Math.random()<.7&&f>=b&&(window.spSampleMarker=!0),window.spSampleMarkerScore=f},location.href===document.referrer?void g():(h=function(){return this._score},i=function(b){f+=b,f>=9999&&(f-=1e3),c(a,f)},j=0,"en-US"!==navigator.language&&(j-=1),document.referrer?"/"===location.pathname&&(document.referrer.includes("google")||document.referrer.includes("yahoo")||document.referrer.includes("bing")||document.referrer.includes("baidu"))?j+=5:location.hostname===e(document.referrer)||(j-=6):j+=7,i(j),void g())}();</script><script>window.cmc_ab_test = Math.floor(Math.random() * 4);</script><script>window.ab = document.referrer.indexOf('/tv/') !== -1 && document.referrer.indexOf(location.hostname) !== -1; window.abok = (document.cookie.indexOf('abok=1') !== -1); if(window.abok){window.ab=true;}; window.ab && (window.spSampleMarker=!0); var gc = function(n) { parts = ("; " + document.cookie).split("; "+n+"="); if (parts.length == 2) return parts.pop().split(";").shift(); }; window.abspl = gc('abspl'); window.absid = gc('absid'); window.arcnt = parseInt(gc('cmc_arcnt'))||0;</script><!-- Google Tag Manager --><script>dataLayer = [{"_":"_","page_type":"articles","category":"world","keywords":"boko haram,nigerian schoolgirl,kidnapped schoolgirl,leah sharibu,jesus christ","article_id":"223629","article_title":"Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians","article_type":"n","reporter":"stoyan-zaimov"}];	dataLayer.push({'ab': window.ab});	!function(t,e){t[e]=t[e]||[],t[e].push({"gtm.start":(new Date).getTime(),event:"gtm.js"})}(window,"dataLayer");</script><script async="async" src="https://www.googletagmanager.com/gtm.js?id=GTM-M3XGPPX"></script><!-- End Google Tag Manager --><script src="//ajax.googleapis.com/ajax/libs/jquery/1.10.1/jquery.min.js"></script><script type="text/javascript" src="//g-4cf9.kxcdn.com/cp/js/base.js"></script> <!-- javascript --><!--[if (lt IE 9)]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><script src="//g-4cf9.kxcdn.com/cp/js/ie.js"></script><link href="http://externalcdn.com/respond-proxy.html" id="respond-proxy" rel="respond-proxy" /><link href="//g-4cf9.kxcdn.com/cp/cross-domain/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" /><script src="//g-4cf9.kxcdn.com/cp/cross-domain/respond.proxy.js"></script><![endif]--><script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "headline": "Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians", "datePublished": "Thu, 03 May 2018 14:36:32 -0400", "dateModified": "Thu, 03 May 2018 14:36:32 -0400", "description": "The mother of a Nigerian Christian schoolgirl who has been kidnapped by Islamic radical group Boko Haram has said that she is proud of her daughter for not denouncing Jesus, while a classmate shared hopes that God might use her to turn her attackers to Christ.", "mainEntityOfPage": "http://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/", "image": { "@type": "ImageObject", "url": "https://cdn6-thechristianpost.netdna-ssl.com/full/102869/chibok.jpg", "height":533, "width": 800 }, "author": { "@type": "Person", "name": "Stoyan Zaimov" }, "publisher": { "@type": "Organization", "name": "Christian Post", "logo": { "@type": "ImageObject", "url": "https://g-29b4.kxcdn.com/cp-m/img/logo-amp.png", "width": 600, "height": 60 } } } </script></head><script>_cp_pagetype='Article';
_cp_mid='151';
_cp_aid='223629_mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians';</script><body class="innerpage" ><input type="checkbox" name="" id="nav-toggle" class="hidden-checkbox"><nav class="site-nav"><ul> <li><a href="https://www.christianpost.com/" >Home</a></li> <li><a href="/church-ministries/">Church & Ministry</a></li> <li><a href="/us/">U.S.</a></li> <li><a href="/world/">World</a></li> <li><a href="/politics/">Politics</a></li> <li><a href="/entertainment/">Entertainment</a></li> <li><a href="/living/">living</a></li> <li><a href="/opinion/">Opinion</a></li> <li class="special"><a href="/buzzvine/">Buzzvine</a></li> <li><a href="https://www.christianpost.com/voices">Voices</a></li> <li><a href="http://www.christianpost.tv/">Video</a></li> <li><a href="http://ipost.christianpost.com/">Ipost</a></li></ul></nav><div class="page"> <input type="checkbox" name="k" id="top-search" class="hidden-checkbox"><form action="/search" class="top-search container"> <div class="inner"> <input type="search" name="k" placeholder="CP search"> <button class="i-search"></button> </div></form> <noscript> <p class="enable-js"> To enjoy our website, you'll need to enable <b>JavaScript</b> in your web browser. Please <a href="http://enable-javascript.com/" target="_blank"><b>click here</b></a> to learn how. </p></noscript> <!--[if lt IE 8]> <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/" target="_blank">upgrade your browser</a> to improve your experience.</p><![endif]--> <header class="site-header-inner site-header-sticky"><div class="container"> <div class="topbar"> <div class="actions"> <label for="nav-toggle" class="nav-toggle i-bars item"></label> <label for="nav-toggle" class="page-overlay"></label> <label for="top-search" class="top-search-toggle i-search item"></label> <div class="logo item"> <a href="https://www.christianpost.com" > <!--[if (!IE 8)&(!IE 7)]><!--><img src="//g-4cf9.kxcdn.com/cp/img/logo.svg" alt="The Christian Post"> <!--<![endif]--> <!--[if (IE 8)&!(IEMobile)]><img src="//g-4cf9.kxcdn.com/cp/img/logo.png" alt="The Christian Post"><![endif]--> </a></div> <h2 class="channel-label item"><a href="/"><strong>CP</strong></a><span></span></h2> </div> <div class="links"> <a href="/newsletter/subscribe" class="item">subscribe</a> <!--<a href="" class="item btn-signin">log in</a>--> <span class="dropdown item cmc-sites"> <span class="current">CMC sites <span class="i-plus"></span></span> <ul class="dd-content"> <li><a href="http://www.crossmap.com/">crossmap</a></li> <li><a href="http://gnli.christianpost.com/">gnl</a></li> </ul> </span> </div> </div></div></header> <div class="container"> <h2 class="channel-label"><a href="/"><strong>CP</strong></a><span><a href="/world/">World</a></span></h2> <div class="article-content main-content"> <div style="position: relative;"> <article class="full-article"> <header> <h1>Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians</h1> <div class="shareline"><!-- Go to www.addthis.com/dashboard to customize your tools --> <a class="facebook i-facebook addthis_button_facebook" href="http://www.facebook.com/sharer.php?u=https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on facebook</a> <a class="twitter i-twitter addthis_button_twitter" href="https://twitter.com/intent/tweet?text=Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians&url=https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on twitter</a> <div class="dropdown"><span class="i-plus"></span> <div class="dd-content"> <h4>Share</h4> <ul> <li><a class="email i-email addthis_button_email"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Email</a></li> <li><a href="print.html" class="print i-print">Print</a></li> <li><a class="facebook i-facebook-alt addthis_button_facebook"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share</a></li> <li><a class="twitter i-twitter addthis_button_twitter"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Tweet</a></li> <li><a class="pinterest i-pinterest addthis_button_pinterest_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Pin</a></li> <li><a class="linkedin i-linkedin-square addthis_button_linkedin"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Linkedin</a></li> <li><a class="google-plus i-google-plus addthis_button_google_plusone_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Google+</a></li> <li><a class="reddit i-reddit addthis_button_reddit"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Reddit</a></li> </ul> <section><form action="//christianpost.us11.list-manage.com/subscribe/post?u=673ab5585713f3c683523744e&amp;id=061f5f47a6" method="post" class="newsletter-box" target="_blank"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="EMAIL" class="user-email " id="mce-EMAIL" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form></section> </div> </div></div><script type="text/javascript">var addthis_config = {"data_track_addressbar":false};</script><script type="text/javascript"> (function(){ var forceLoadTimeout; var delayLoad = true; var forceLoadFunc = function () { docReadyCompFunc(true); }; var docReadyCompFunc = function (forceLoad) { if (delayLoad && document.readyState !== 'complete' && forceLoad !== true) {return;} if (delayLoad) { document.removeEventListener('readystatechange', docReadyCompFunc); clearTimeout(forceLoadTimeout); } var jstag = document.createElement("script"); jstag.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ephraimju"; document.body.appendChild(jstag); }; if (delayLoad) { document.addEventListener('readystatechange', docReadyCompFunc); forceLoadTimeout = setTimeout(forceLoadFunc, 3000); } if (!delayLoad) { docReadyCompFunc(); } })();</script><div class="byline">By <span itemprop="author creator" itemscope="" itemtype="http://schema.org/Person" itemid="https://www.christianpost.com/author/stoyan-zaimov/"> <a class="reporter" href="https://www.christianpost.com/author/stoyan-zaimov/" itemprop="url"> <span itemprop="name">Stoyan Zaimov</span> </a> <span> </span>, <span itemprop="jobTitle">Christian Post Reporter</span> | <time datetime="2018-05-03T14:36:32-04:00" pubdate="" itemprop="datePublished dateModified">May 3, 2018 2:36 PM</time> </span></div></header> <section><figure class="centered" itemprop="image" itemscope itemtype="http://schema.org/ImageObject" itemid="https://cdn6-thechristianpost.netdna-ssl.com/full/102869/chibok.jpg"><img class="full" src="https://cdn6-thechristianpost.netdna-ssl.com/full/102869/590-393/chibok.jpg" height="393" width="590" /><meta itemprop="width" content="590"><meta itemprop="height" content="393"><figcaption><span class="credit"> REUTERS/Afolabi Sotunde</span>One of the 21 Chibok school girls released by Boko Haram carries her baby during their visit to meet President Muhammadu Buhari In Abuja, Nigeria October 19, 2016.</figcaption></figure><p>The mother of a Nigerian Christian schoolgirl who has been kidnapped by Islamic radical group Boko Haram has said that she is proud of her daughter for not denouncing Jesus, while a classmate shared hopes that God might use her to turn her attackers to Christ.</p><p>"I am so proud of my Leah because she did not denounce Christ," the mother, Rebecca Sharibu, said of her daughter, 15-year-old Leah, in an article posted by <a href="https://www.opendoorsusa.org/christian-persecution/mother-of-boko-haram-captive-begs-please-dont-tire-of-praying-for-my-leah/" target="_blank">Open Doors USA</a>&nbsp;last week.</p><p>"And because of that, I know God will never forsake her. When she went away to school, I gave her a copy of the Bible so she could have her personal devotions even when I am not there. As her mother, I know her to be an obedient daughter, respectful and someone who puts others before herself."</p><p>Leah was one of over <a href="https://www.christianpost.com/news/boko-haram-frees-over-100-schoolgirls-holds-christian-captive-for-refusing-to-renounce-christ-221921/">100 schoolgirls kidnapped</a>&nbsp;from a secondary school in the town of Dapchi during a Boko Haram raid in February. While all of the other schoolgirls have been freed, she remains the lone student still in captivity.</p><p>What is more, testimonies have emerged revealing that Leah was offered her freedom by the radicals if she denounced her faith, but she has refused to do so.</p><p>Sharibu recalled her terror on the night of the attack when she found out that her daughter had been taken, but said she is finding courage in the prayers of Christians from around the world.</p><aside class="aside-left"><section><form action="/services/subscribe/process.php" method="post" class="newsletter-box" target="_blank" id="msgForm"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="email" class="user-email " id="mce-EMAIL" required><input type="hidden" name="newsletter_mode" value="article"><input type="hidden" name="rel_href" value="/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/"><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form><div class="close msg_close" js-close></div></section><script>$( "#msgForm" ).submit(function( event ){ event.preventDefault();var $form = $( this ),url = $form.attr("action");var posting = $.post(url, { email: $("#mce-EMAIL").val() });posting.done(function(data) { $( ".msg_close" ).after(data);});});</script><section class="has-story-divider has-left-figure relatedArticle"><h3 class="title">Related</h3><article><figure><a href="/news/christians-violated-betrayed-nigerian-bishops-ask-buhari-to-resign-over-horrific-mass-slaughters-223486/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/127029/500-281/nigeria.jpg"></a></figure><h4 class="h3-d"><a href="/news/christians-violated-betrayed-nigerian-bishops-ask-buhari-to-resign-over-horrific-mass-slaughters-223486/" target="_blank">Christians 'Violated, Betrayed': Nigerian Bishops Ask Buhari to Resign Over Horrific Mass Slaughters</a></h4> </article><article><figure><a href="/news/trump-to-meet-nigerian-president-will-he-discuss-killing-of-christians-223482/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/125691/500-281/fulani-herdsmen.jpg"></a></figure><h4 class="h3-d"><a href="/news/trump-to-meet-nigerian-president-will-he-discuss-killing-of-christians-223482/" target="_blank">Trump to Meet Nigerian President; Will He Discuss Killing of Christians?</a></h4> </article><article><figure><a href="/news/justin-welby-pleads-rescue-christian-girl-refuses-convert-islam-buhari-meeting-222888/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/130083/500-281/justin-welby-and-muhammadu-buhari.jpg"></a></figure><h4 class="h3-d"><a href="/news/justin-welby-pleads-rescue-christian-girl-refuses-convert-islam-buhari-meeting-222888/" target="_blank">Justin Welby Pleads for Rescue of Christian Girl Who Refuses to Convert to Islam in Buhari Meeting</a></h4> </article><article><figure><a href="/news/boko-haram-frees-over-100-schoolgirls-holds-christian-captive-for-refusing-to-renounce-christ-221921/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/129448/500-281/boko-haram-dapchi-girls.png"></a></figure><h4 class="h3-d"><a href="/news/boko-haram-frees-over-100-schoolgirls-holds-christian-captive-for-refusing-to-renounce-christ-221921/" target="_blank">Boko Haram Frees Over 100 Schoolgirls, Holds Christian Captive for Refusing to Renounce Christ</a></h4> </article></section></aside><p>"I want to plead that Christians not grow tired of praying for her — 'til she returns," the mother said.</p><p>"My heart is heavy but joyful in this trial because my Leah refused to denounce Christ, just as our church says, 'being joyful in suffering.' My encouragement is this: I know that even if Leah is dead, she is with the Lord."</p><p>Affodia Andrawus, a 19-year-old Christian classmate of Leah's, who witnessed the raid firsthand but managed to escape, said she has faith that God will use her friend for a higher purpose.</p><p>"I believe that God allowed Leah to be the only Christian that was abducted for a reason — so that through her, the world and even her abductors would come to know Christ. Leah indeed has spread the Gospel to all the world," the girl said.</p><p>Andrawus also attested to Leah's strong character.</p><p>"No matter how much Leah is mistreated or insulted by other students, she will never retaliate. Instead, Leah will look for a way to make peace with everyone," she shared.</p><p>"If anyone is sick among the Christians, Leah is always the first to go and greet and pray for that person," Affodia said. "Her life is really an example for all to follow."</p><p>Andrawus recalled the attack on the Government Girls School on Feb. 19, noting that the students were sitting down to eat after study time when gunshots rang out.</p><p>"We were trying to get ourselves coordinated when we heard more gunshots, and this time a bullet fell in front of the hostel where we were. The gunshots increased a lot, so we (Christians) decided to hold hands and run away. We knew we would be the target," she said.</p><p>The schoolgirl recounted how the girls ran out, but many of them were caught by the militants, including Leah, who were thrown inside a parked Boko Haram truck.</p><p>"The rest of us jumped the fence and kept running. We ran to a thick bush behind our school and hid there that night," she said.</p><p>Major Christian leaders, including Archbishop of Canterbury Justin Welby, <a href="https://www.christianpost.com/news/justin-welby-pleads-rescue-christian-girl-refuses-convert-islam-buhari-meeting-222888/">have brought up</a>&nbsp;Leah's fate in direct meetings with Nigerian President Muhammadu Buhari.</p><p>"I urged the president to do everything possible to secure her release," Welby noted of his meeting with Buhari in April.</p><div class="article_credit">Follow Stoyan Zaimov on Facebook: <a href="https://www.facebook.com/CPSZaimov" target="_blank">CPSZaimov</a></div> </section> <div class="shareline"><!-- Go to www.addthis.com/dashboard to customize your tools --> <a class="facebook i-facebook addthis_button_facebook" href="http://www.facebook.com/sharer.php?u=https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on facebook</a> <a class="twitter i-twitter addthis_button_twitter" href="https://twitter.com/intent/tweet?text=Mother of Kidnapped Nigerian Schoolgirl Who Refuses to Denounce Jesus Has Urgent Plea for Christians&url=https://www.christianpost.com/news/mother-of-kidnapped-nigerian-schoolgirl-who-refuses-to-denounce-jesus-has-urgent-plea-for-christians-223629/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on twitter</a> <div class="dropdown"><span class="i-plus"></span> <div class="dd-content"> <h4>Share</h4> <ul> <li><a class="email i-email addthis_button_email"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Email</a></li> <li><a href="print.html" class="print i-print">Print</a></li> <li><a class="facebook i-facebook-alt addthis_button_facebook"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share</a></li> <li><a class="twitter i-twitter addthis_button_twitter"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Tweet</a></li> <li><a class="pinterest i-pinterest addthis_button_pinterest_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Pin</a></li> <li><a class="linkedin i-linkedin-square addthis_button_linkedin"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Linkedin</a></li> <li><a class="google-plus i-google-plus addthis_button_google_plusone_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Google+</a></li> <li><a class="reddit i-reddit addthis_button_reddit"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Reddit</a></li> </ul> <section><form action="//christianpost.us11.list-manage.com/subscribe/post?u=673ab5585713f3c683523744e&amp;id=061f5f47a6" method="post" class="newsletter-box" target="_blank"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="EMAIL" class="user-email " id="mce-EMAIL" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form></section> </div> </div></div><script type="text/javascript">var addthis_config = {"data_track_addressbar":false};</script><script type="text/javascript"> (function(){ var forceLoadTimeout; var delayLoad = true; var forceLoadFunc = function () { docReadyCompFunc(true); }; var docReadyCompFunc = function (forceLoad) { if (delayLoad && document.readyState !== 'complete' && forceLoad !== true) {return;} if (delayLoad) { document.removeEventListener('readystatechange', docReadyCompFunc); clearTimeout(forceLoadTimeout); } var jstag = document.createElement("script"); jstag.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ephraimju"; document.body.appendChild(jstag); }; if (delayLoad) { document.addEventListener('readystatechange', docReadyCompFunc); forceLoadTimeout = setTimeout(forceLoadFunc, 3000); } if (!delayLoad) { docReadyCompFunc(); } })();</script> </article> <div class="comment"></div> </div> <div class="sidebar" style="position:inherit;"> <section> <header class="heading-line">Most Popular</header> <ul class="has-right-media graybox"> <li> <div class="media-body"><a href="/news/christian-college-student-sang-jesus-loves-me-before-she-was-shot-dead-in-waffle-house-223491/">Christian College Student Sang 'Jesus Loves Me' Before She Was Shot Dead in Waffle House</a></div> <figure> <a href="/news/christian-college-student-sang-jesus-loves-me-before-she-was-shot-dead-in-waffle-house-223491/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/130535/138-86-50/deebony-groves.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/beth-moore-slams-christians-who-demonize-divorce-worst-sin-we-do-not-submit-to-abuse-223520/">Beth Moore Slams Christians Who 'Demonize' Divorce as Worst Sin: 'We Do Not Submit to Abuse'</a></div> <figure> <a href="/news/beth-moore-slams-christians-who-demonize-divorce-worst-sin-we-do-not-submit-to-abuse-223520/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/129807/138-86-50/beth-moore.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/supernatural-miracles-are-happening-today-more-than-many-realize-john-piper-says-223494/">Supernatural Miracles Are Happening Today More Than Many Realize, John Piper Says</a></div> <figure> <a href="/news/supernatural-miracles-are-happening-today-more-than-many-realize-john-piper-says-223494/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/129795/138-86-50/john-piper.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/franklin-graham-lessons-from-father-billy-evangelicals-politics-hell-223495/">Franklin Graham on Lessons From His Father, Evangelicals, Politics and Hell</a></div> <figure> <a href="/news/franklin-graham-lessons-from-father-billy-evangelicals-politics-hell-223495/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/130540/138-86-50/billy-graham-and-franklin.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/southern-baptist-seminary-president-paige-patterson-responds-abused-wives-stay-with-husbands-223489/">Southern Baptist Leader Responds to Charge That He Wants Abused Wives to Stay With Husbands</a></div> <figure> <a href="/news/southern-baptist-seminary-president-paige-patterson-responds-abused-wives-stay-with-husbands-223489/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/5286/138-86-50/img.jpg"></a> </figure> </li> </ul></section><section> <header class="heading-line">MUST READ</header> <ul class="has-right-media graybox"> <li> <div class="media-body"><a href="/news/franklin-graham-lessons-from-father-billy-evangelicals-politics-hell-223495/">Franklin Graham on Lessons From His Father, Evangelicals, Politics and Hell</a></div> <figure> <a href="/news/franklin-graham-lessons-from-father-billy-evangelicals-politics-hell-223495/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/40931/138-86-50-50/img.jpg" alt="" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/prisoners-turned-missionaries-societal-barriers-after-serving-time-second-chance-month-223233/">Prisoners Turned Missionaries Describe Societal Barriers They Faced After Serving Their Time</a></div> <figure> <a href="/news/prisoners-turned-missionaries-societal-barriers-after-serving-time-second-chance-month-223233/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/130378/138-86-4-16/roy-yamamoto.jpg" alt="roy-yamamoto" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/schools-youth-and-violence-where-do-we-go-from-here-222981/">Schools, Youth and Violence: Where Do We Go From Here?</a></div> <figure> <a href="/news/schools-youth-and-violence-where-do-we-go-from-here-222981/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/127501/138-86/candlelight-vigil.jpg" alt="candlelight-vigil" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/school-shootings-mental-health-or-spiritual-warfare-222905/">School Shootings: Mental Health or Spiritual Warfare?</a></div> <figure> <a href="/news/school-shootings-mental-health-or-spiritual-warfare-222905/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/127550/138-86/florida-school-shooting.jpg" alt="florida-school-shooting" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/youth-schools-and-violence-what-can-churches-do-222133/">Youth, Schools and Violence: What Can Churches Do?</a></div> <figure> <a href="/news/youth-schools-and-violence-what-can-churches-do-222133/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/127610/138-86/florida-school-shooting.jpg" alt="florida-school-shooting" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> </ul></section> </div> </div> </div> <footer class="site-footer container"> <nav class="links"> <div class="logo item"> <a href="https://www.christianpost.com" > <!--[if (!IE 8)&(!IE 7)]><!--><img src="//g-4cf9.kxcdn.com/cp/img/logo.svg" alt="The Christian Post"> <!--<![endif]--> <!--[if (IE 8)&!(IEMobile)]><img src="//g-4cf9.kxcdn.com/cp/img/logo.png" alt="The Christian Post"><![endif]--> </a></div> <ul class="primary"> <li><a href="/aboutus/">About Us</a></li> <li><a href="/aboutus/contact/">Contact Us</a></li> <li><a href="/services/christian-advertising/">Media Kit</a></li> <li><a href="/archive">Archives</a></li> <li><a href="/aboutus/corrections/">Corrections</a></li> <li><a href="/aboutus/general/">Disclaimer</a></li> <li><a href="http://ww2.christianpost.com/aboutus/jobs.html">Careers</a></li> </ul> <ul> <li><a href="/aboutus/terms/">Terms</a></li> <li><a href="/aboutus/privacy/">Privacy policy</a></li> </ul> </nav> <div class="footbar"> <div class="copyright">&copy; 2018 The Christian Post , INC. All Rights Reserved.</div> <div class="cmci">The Christian Post is part of <a href="http://www.cmcigroup.com/" target="_blank">CMC <span class="cmci-logo"></span></a></div> </div></footer> <script src="//g-4cf9.kxcdn.com/cp/js/script.js"></script><!-- Quantcast Tag --><script type="text/javascript">var _qevents = _qevents || [];
(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();
_qevents.push({
qacct:"p-f3_tFTzTnk8n2"
});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-f3_tFTzTnk8n2.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!-- End Quantcast tag --><!--chartbeat--><!-- <script type="text/javascript">var _sf_async_config={uid:24907,domain:"christianpost.com"};
(function(){ function loadChartbeat() { window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") + "js/chartbeat.js"); document.body.appendChild(e); } var oldonload = window.onload; window.onload = (typeof window.onload != 'function') ? loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();</script> --><!--chartbeat--><script src="//g-4cf9.kxcdn.com/track.js"></script><script>(function(){ if (window.ab) {return;} page_count('cp','223629','151','72');add_pixel('223629','764', 'cp', 'www' );
})();</script><script async defer src="//platform.instagram.com/en_US/embeds.js"></script></div></body></html>