<!doctype html><!--[if (IE 8)&!(IEMobile)]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if (IE 9)&!(IEMobile)]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 9]><!--><html class="no-js" lang="en"><!--<![endif]--><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better</title><meta name="title" content="John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better"><meta name="description" content="Former Presidents George W. Bush and Barack Obama, both political rivals of the late Senator John McCain, delivered eulogies honoring him as an exemplar of American ideals."><meta name="Keywords" content="john mccain,george w. bush,barack obama"><meta property="og:title" content="John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better"><meta property="og:description" content="Former Presidents George W. Bush and Barack Obama, both political rivals of the late Senator John McCain, delivered eulogies honoring him as an exemplar of American ideals."><meta property="og:image" content="https://data.christianpost.com/full/132745/george-w-bush.png"><meta property="og:type" content="article"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@ChristianPost"><meta name="twitter:title" content="John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better"><meta name="twitter:description" content="Former Presidents George W. Bush and Barack Obama, both political rivals of the late Senator John McCain, delivered eulogies honoring him as an exemplar of American ideals."><meta name="twitter:image" content="https://data.christianpost.com/full/132745/george-w-bush.png"><meta property="og:url" content="https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/"><meta name="news_keywords" content="john mccain,george w. bush,barack obama"><meta name="HandheldFriendly" content="True"><meta name="MobileOptimized" content="320"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><!-- favicons --><link rel="apple-touch-icon" sizes="180x180" href="//g-4cf9.kxcdn.com/cp/img/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon-16x16.png" sizes="16x16"><link rel="manifest" href="//g-4cf9.kxcdn.com/cp/img/favicons/manifest.json"><link rel="mask-icon" href="//g-4cf9.kxcdn.com/cp/img/favicons/safari-pinned-tab.svg" color="#2577cf"><link rel="shortcut icon" href="//g-4cf9.kxcdn.com/cp/img/favicons/favicon.ico"><meta name="msapplication-config" content="//g-4cf9.kxcdn.com/cp/img/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><meta property="fb:app_id" content="1879686555693183"> <!-- publication page --> <link rel="canonical" href="https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/" /> <link rel="amphtml" href="https://www.christianpost.com/amp/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/"> <!-- publication page --> <!-- css --><link rel="stylesheet" href="//g-4cf9.kxcdn.com/cp/css/main.css"><script>-1!==location.search.indexOf("abspl=ZmJ2aXJhbA")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","ZmJ2aXJhbA","; path=/;"].join(""));-1!==location.search.indexOf("abspl=b3V0YnJhaW4")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","b3V0YnJhaW4","; path=/;"].join(""));-1!==location.search.indexOf("abspl=YmluZ2Fkcw")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","YmluZ2Fkcw","; path=/;"].join(""));!function(){var a=location.href;var p=function(){var i,t={},s=/=/.test(a),n=(s?a:location.search.substring(1)).split("&");for(p in n)i=n[p].split("="),t[i[0]]=i[1];return!a||s?t:t[a]}();p&&p.absid&&(document.cookie=["absid","=",p.absid,"; path=/;"].join(""));}();</script> <script>!function(){var a,b,c,d,e,f,g,h,i,j,k="cssc",l=new Date,m=new Date;return m.setDate(1),m.setMonth(m.getMonth()-1),a=k+l.getYear()+l.getMonth(),b=k+m.getYear()+m.getMonth(),c=function(a,b){var c=[a,"=",JSON.stringify(b),"; path=/;expires="+new Date(Date.now()+5184e6).toGMTString()].join("");document.cookie=c},d=function(a,b,c){var d=document.cookie.match(new RegExp(a+"=([^;]+)"));return d?(d=JSON.parse(d[1]),d||0):(d=document.cookie.match(new RegExp(b+"=([^;]+)")))?(d=JSON.parse(d[1]),Math.floor((d||0)/2)):(d=document.cookie.match(new RegExp(a+"=([^;]+)")),d&&(d=JSON.parse(d[1])),d||0)},e=function(a){var b;return b=a.indexOf("://")>-1?a.split("/")[2]:a.split("/")[0],b=b.split(":")[0]},f=d(a,b,k),g=function(){var a=0,b=36,c=(new Date).getHours(),d=(new Date).getDay();(c>19||c<7||Math.random()<.5&&12==c)&&(a=9999),0!=d&&6!=d||(a=9999),window.spSampleMarker=!(f>=a),Math.random()<.7&&f>=b&&(window.spSampleMarker=!0),window.spSampleMarkerScore=f},location.href===document.referrer?void g():(h=function(){return this._score},i=function(b){f+=b,f>=9999&&(f-=1e3),c(a,f)},j=0,"en-US"!==navigator.language&&(j-=1),document.referrer?"/"===location.pathname&&(document.referrer.includes("google")||document.referrer.includes("yahoo")||document.referrer.includes("bing")||document.referrer.includes("baidu"))?j+=5:location.hostname===e(document.referrer)||(j-=6):j+=7,i(j),void g())}();</script><script>window.cmc_ab_test = Math.floor(Math.random() * 4);</script><script>window.ab = document.referrer.indexOf('/tv/') !== -1 && document.referrer.indexOf(location.hostname) !== -1; window.abok = (document.cookie.indexOf('abok=1') !== -1); if(window.abok){window.ab=true;}; window.ab && (window.spSampleMarker=!0); var gc = function(n) { parts = ("; " + document.cookie).split("; "+n+"="); if (parts.length == 2) return parts.pop().split(";").shift(); }; window.abspl = gc('abspl'); window.absid = gc('absid'); window.arcnt = parseInt(gc('cmc_arcnt'))||0;</script><!-- Google Tag Manager --><script>dataLayer = [{"_":"_","page_type":"articles","category":"us","keywords":"john mccain,george w. bush,barack obama","article_id":"227132","article_title":"John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better","article_type":"n","reporter":"napp-nazworth"}];	dataLayer.push({'ab': window.ab});	!function(t,e){t[e]=t[e]||[],t[e].push({"gtm.start":(new Date).getTime(),event:"gtm.js"})}(window,"dataLayer");</script><script async="async" src="https://www.googletagmanager.com/gtm.js?id=GTM-M3XGPPX"></script><!-- End Google Tag Manager --><script src="//ajax.googleapis.com/ajax/libs/jquery/1.10.1/jquery.min.js"></script><script type="text/javascript" src="//g-4cf9.kxcdn.com/cp/js/base.js"></script> <!-- javascript --><!--[if (lt IE 9)]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><script src="//g-4cf9.kxcdn.com/cp/js/ie.js"></script><link href="http://externalcdn.com/respond-proxy.html" id="respond-proxy" rel="respond-proxy" /><link href="//g-4cf9.kxcdn.com/cp/cross-domain/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" /><script src="//g-4cf9.kxcdn.com/cp/cross-domain/respond.proxy.js"></script><![endif]--><script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "headline": "John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better", "datePublished": "Sat, 01 Sep 2018 13:47:00 -0400", "dateModified": "Sat, 01 Sep 2018 13:47:00 -0400", "description": "Former Presidents George W. Bush and Barack Obama, both political rivals of the late Senator John McCain, delivered eulogies honoring him as an exemplar of American ideals.", "mainEntityOfPage": "http://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/", "image": { "@type": "ImageObject", "url": "https://cdn6-thechristianpost.netdna-ssl.com/full/132745/george-w-bush.png", "height":437, "width": 800 }, "author": { "@type": "Person", "name": "Napp Nazworth" }, "publisher": { "@type": "Organization", "name": "Christian Post", "logo": { "@type": "ImageObject", "url": "https://g-29b4.kxcdn.com/cp-m/img/logo-amp.png", "width": 600, "height": 60 } } } </script></head><script>_cp_pagetype='Article';
_cp_mid='80';
_cp_aid='227132_john-mccain-rivals-george-w-bush-barack-obama-honor-hero-who-frustrated-made-them-better';</script><body class="innerpage" ><input type="checkbox" name="" id="nav-toggle" class="hidden-checkbox"><nav class="site-nav"><ul> <li><a href="https://www.christianpost.com/" >Home</a></li> <li><a href="/church-ministries/">Church & Ministry</a></li> <li><a href="/us/">U.S.</a></li> <li><a href="/world/">World</a></li> <li><a href="/politics/">Politics</a></li> <li><a href="/entertainment/">Entertainment</a></li> <li><a href="/living/">living</a></li> <li><a href="/opinion/">Opinion</a></li> <li class="special"><a href="/buzzvine/">Buzzvine</a></li> <li><a href="https://www.christianpost.com/voices">Voices</a></li> <li><a href="http://ipost.christianpost.com/">Ipost</a></li></ul></nav><div class="page" > <input type="checkbox" name="k" id="top-search" class="hidden-checkbox"><form action="/search" class="top-search container"> <div class="inner"> <input type="search" name="k" placeholder="CP search"> <button class="i-search"></button> </div></form> <noscript> <p class="enable-js"> To enjoy our website, you'll need to enable <b>JavaScript</b> in your web browser. Please <a href="http://enable-javascript.com/" target="_blank"><b>click here</b></a> to learn how. </p></noscript> <!--[if lt IE 8]> <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/" target="_blank">upgrade your browser</a> to improve your experience.</p><![endif]--> <header class="site-header-inner"><div class="container"> <div class="topbar"> <div class="actions"> <label for="nav-toggle" class="nav-toggle i-bars item"></label> <label for="nav-toggle" class="page-overlay"></label> <label for="top-search" class="top-search-toggle i-search item"></label> <div class="logo item"> <a href="https://www.christianpost.com" > <!--[if (!IE 8)&(!IE 7)]><!--><img src="//g-4cf9.kxcdn.com/cp/img/logo.svg" alt="The Christian Post"> <!--<![endif]--> <!--[if (IE 8)&!(IEMobile)]><img src="//g-4cf9.kxcdn.com/cp/img/logo.png" alt="The Christian Post"><![endif]--> </a></div> <h2 class="channel-label item"><a href="/"><strong>CP</strong></a><span></span></h2> </div> <div class="links"> <a href="/newsletter/subscribe" class="item">subscribe</a> <!--<a href="" class="item btn-signin">log in</a>--> <span class="dropdown item cmc-sites"> <span class="current">CMC sites <span class="i-plus"></span></span> <ul class="dd-content"> <li><a href="http://www.crossmap.com/">crossmap</a></li> <li><a href="http://gnli.christianpost.com/">gnl</a></li> </ul> </span> </div> </div></div></header> <div class="container"> <h2 class="channel-label"><a href="/"><strong>CP</strong></a><span><a href="/us/">U.S.</a></span></h2> <div class="article-content main-content sticky-holder"> <div> <article class="full-article"> <header> <h1>John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better</h1> <div class="shareline"><!-- Go to www.addthis.com/dashboard to customize your tools --> <a class="facebook i-facebook addthis_button_facebook" href="http://www.facebook.com/sharer.php?u=https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on facebook</a> <a class="twitter i-twitter addthis_button_twitter" href="https://twitter.com/intent/tweet?text=John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better&url=https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on twitter</a> <div class="dropdown"><span class="i-plus"></span> <div class="dd-content"> <h4>Share</h4> <ul> <li><a class="email i-email addthis_button_email"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Email</a></li> <li><a href="print.html" class="print i-print">Print</a></li> <li><a class="facebook i-facebook-alt addthis_button_facebook"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share</a></li> <li><a class="twitter i-twitter addthis_button_twitter"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Tweet</a></li> <li><a class="pinterest i-pinterest addthis_button_pinterest_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Pin</a></li> <li><a class="linkedin i-linkedin-square addthis_button_linkedin"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Linkedin</a></li> <li><a class="google-plus i-google-plus addthis_button_google_plusone_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Google+</a></li> <li><a class="reddit i-reddit addthis_button_reddit"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Reddit</a></li> </ul> <!-- <section><form action="//christianpost.us11.list-manage.com/subscribe/post?u=673ab5585713f3c683523744e&amp;id=061f5f47a6" method="post" class="newsletter-box" target="_blank"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="EMAIL" class="user-email " id="mce-EMAIL" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form></section> --> </div> </div></div><script type="text/javascript">var addthis_config = {"data_track_addressbar":false};</script><script type="text/javascript"> (function(){ var forceLoadTimeout; var delayLoad = true; var forceLoadFunc = function () { docReadyCompFunc(true); }; var docReadyCompFunc = function (forceLoad) { if (delayLoad && document.readyState !== 'complete' && forceLoad !== true) {return;} if (delayLoad) { document.removeEventListener('readystatechange', docReadyCompFunc); clearTimeout(forceLoadTimeout); } var jstag = document.createElement("script"); jstag.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ephraimju"; document.body.appendChild(jstag); }; if (delayLoad) { document.addEventListener('readystatechange', docReadyCompFunc); forceLoadTimeout = setTimeout(forceLoadFunc, 3000); } if (!delayLoad) { docReadyCompFunc(); } })();</script><div class="byline">By <span itemprop="author creator" itemscope="" itemtype="http://schema.org/Person" itemid="https://www.christianpost.com/author/napp-nazworth/"> <a class="reporter" href="https://www.christianpost.com/author/napp-nazworth/" itemprop="url"> <span itemprop="name">Napp Nazworth</span> </a> <span> </span>, <span itemprop="jobTitle">Christian Post Reporter</span> | <time datetime="2018-09-01T13:47:00-04:00" pubdate="" itemprop="datePublished dateModified">Sep 1, 2018 1:47 PM</time> </span> </div></header> <section id="article_content"><figure class="centered" itemprop="image" itemscope itemtype="http://schema.org/ImageObject" itemid="https://cdn6-thechristianpost.netdna-ssl.com/full/132745/george-w-bush.png"><img class="full" src="https://cdn6-thechristianpost.netdna-ssl.com/full/132745/590-322-67-31/george-w-bush.png" height="322" width="590" /><meta itemprop="width" content="590"><meta itemprop="height" content="322"><figcaption><span class="credit"> (Photo: Screengrab, C-Span)</span>Former President George W. Bush speaking at the funeral of U.S. Sen. John McCain, R-Ariz., Washington National Cathedral, Washington, D.C., September 1, 2018.</figcaption></figure><p>Former Presidents George W. Bush and Barack Obama, both political rivals of the late Senator John McCain, delivered eulogies honoring him as an exemplar of American ideals.</p><p>"What better way to get a last laugh than to make George and I say nice things about him to a national audience," Obama joked to laughter from the dignitaries in attendance.</p><p>McCain had asked Bush and Obama to speak at his funeral sometime after he was diagnosed with cancer about one year ago. A congressman and senator since 1982, McCain ran for president twice, and was bested by Bush during the 2000 Republican nomination contests, and by Obama in the 2008 general election.</p><p>Both former presidents recalled McCain as both bipartisan and hard-headed, contrarian and diplomatic, humorous and tempestuous.</p><p>"Back in the day, he could frustrate me, and I know he'd say the same thing about me. But he also made me better," Bush said.</p><p>Obama made a similar point in his speech: "He made us better presidents."</p><p>In the last few years of his life, McCain was notable for his opposition to current President Donald Trump. Remarking on McCain's heroism and 5 years spent as a prisoner of war in Vietnam, Trump, who did not serve in the military due to bone spurs, said in 2015, "He was captured. I like heroes who weren't captured."</p><p>Several of the eulogies contained subtle and not-so-subtle rebukes of Trump.</p><p>As we "mourn the passing of American greatness, the real thing, not cheap rhetoric from men who will never come near the sacrifice he gave so willingly, nor the opportunistic appropriation of those who live lives of comfort and privilege while he suffered and served," daughter Meghan McCain said.</p><p>"The America of John McCain has no need to be made great again because America was always great," she added to a rare applause from the audience.</p><figure class="centered" itemprop="image" itemscope itemtype="http://schema.org/ImageObject" itemid="https://cdn6-thechristianpost.netdna-ssl.com/full/132746/barack-obama.png"><img class="full" src="https://cdn6-thechristianpost.netdna-ssl.com/full/132746/590-329-58-30/barack-obama.png" height="329" width="590" /><meta itemprop="width" content="590"><meta itemprop="height" content="329"><figcaption><span class="credit"> (Photo: Screengrab, C-Span)</span>Former President Barack Obama speaking at the funeral of U.S. Sen. John McCain, R-Ariz., Washington National Cathedral, Washington, D.C., September 1, 2018.</figcaption></figure><p>In what could be a description of Trump, Obama said, "So much of our politics, our public life, our public discourse can seem small and mean and petty. Trafficking in bombastic manufactured outrage, it's politics that pretends to be brave and tough, but in fact is born of fear. John called on us to be bigger than that. He called on us to be better than that."</p><aside class="aside-left"><section><form action="/services/subscribe/process.php" method="post" class="newsletter-box" target="_blank" id="msgForm"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="email" class="user-email " id="mce-EMAIL" required><input type="hidden" name="newsletter_mode" value="article"><input type="hidden" name="rel_href" value="/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132/"><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form><div class="close msg_close" js-close></div></section><script>$( "#msgForm" ).submit(function( event ){ event.preventDefault();var $form = $( this ),url = $form.attr("action");var posting = $.post(url, { email: $("#mce-EMAIL").val() });posting.done(function(data) { $( ".msg_close" ).after(data);});});</script><section class="has-story-divider has-left-figure relatedArticle"><h3 class="title">Related</h3><article><figure><a href="/news/lifelong-episcopalian-senator-john-mccain-remembered-hero-stood-quietly-faith-227024/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/114739/500-281-48-42/senator-john-mccain.jpg"></a></figure><h4 class="h3-d"><a href="/news/lifelong-episcopalian-senator-john-mccain-remembered-hero-stood-quietly-faith-227024/" target="_blank">Lifelong Episcopalian Senator John McCain Remembered as 'Hero' Who Stood Quietly for His Faith</a></h4> </article><article><figure><a href="/news/john-mccain-doesnt-want-trump-funeral-obama-eulogist-instead-223721/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/114739/500-281-48-42/senator-john-mccain.jpg"></a></figure><h4 class="h3-d"><a href="/news/john-mccain-doesnt-want-trump-funeral-obama-eulogist-instead-223721/" target="_blank">John McCain Doesn't Want Trump at His Funeral, Wants Obama as Eulogist Instead</a></h4> </article><article><figure><a href="/news/reactions-death-john-mccain-227012/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/62713/500-281/img.jpg"></a></figure><h4 class="h3-d"><a href="/news/reactions-death-john-mccain-227012/" target="_blank">7 Reactions to the Death of John McCain</a></h4> </article><article><figure><a href="/news/3-facts-explain-john-mccain-popularity-227082/" target="_blank"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/102733/500-281/john-mccain-and-bernie-sanders.jpg"></a></figure><h4 class="h3-d"><a href="/news/3-facts-explain-john-mccain-popularity-227082/" target="_blank">3 Facts Explain John McCain's Popularity</a></h4> </article></section></aside><p>Trump <a href="https://www.usatoday.com/story/news/politics/2018/09/01/donald-trump-golf-club-john-mccain-funeral-national-cathedral/1173143002/" target="_blank">played golf</a>&nbsp;during the service, and also tweeted about trade with Canada.</p><p>Both Bush and Obama spoke about McCain's willingness to buck his own Republican Party when he thought it was the right thing to do.</p><p>"At various points throughout his long career, John confronted policies and practices that he believed were unworthy of his country. To the face of those in authority, John McCain would insist: We are better than this. America is better than this," Bush said.</p><p>Obama recalled McCain had defended his patriotism while running against him. "I was grateful, but not surprised," he said.</p><p>Bush said McCain's politics were based upon an understanding of the dignity of every human life: "He respected the dignity inherent in every life. A dignity that does not stop at borders and cannot be erased by dictators."</p><p>Russell Moore, president of the Southern Baptist Convention's Ethics & Religious Liberty Commission, <a href="https://twitter.com/drmoore/status/1035917814324973575" target="_blank">tweeted</a>, "This John McCain funeral is inspiring — a reminder that honor and statesmanship and maturity in statecraft are still possible." And <a href="https://twitter.com/drmoore/status/1035918191539703809" target="_blank">added</a>, "And dignity. And respect."</p><p>Columnist and commentator <a href="https://twitter.com/mattklewis/status/1035922706435334144" target="_blank">Matt Lewis noted</a>, "This is the most positive national exposure to Christianity since the royal wedding."</p><p>Fox News' Todd Starnes didn't appreciate some of the anti-Trump sentiments expressed at the funeral. "It's typically bad form to turn memorial services into platforms to bad mouth and smear people. #sad," he <a href="https://twitter.com/toddstarnes/status/1035921657737740289" target="_blank">tweeted</a>. <a href="https://twitter.com/toddstarnes/status/1035925962783907841" target="_blank">Adding</a>, "There was a time in American history when you could tell the difference between a funeral and a political rally."</p><p>Hymns sung during the service included, "Eternal Father, Strong to Save," "My Country 'Tis of Thee," "Amazing Grace," "Battle Hymn of the Republic," "The Lord Is My Shepherd," "How Great Thou Art," and "America the Beautiful."</p><p>Opera singer Renée Fleming sang McCain's favorite song, "Danny Boy."</p><p>Former Sen. Kelly Ayotte read from Wisdom 3:1-5, 9, and Sen. Lindsey Graham read John 15:12-13.</p><p>McCain will be laid to rest Sunday at the U.S. Naval Academy.</p><div class="article_credit">Napp Nazworth, Ph.D., is political analyst and politics editor for The Christian Post.<br />Contact: <a href="mailto:napp.nazworth@christianpost.com">napp.nazworth@christianpost.com</a>, <a href="http://twitter.com/NappNazworth">@NappNazworth</a> (Twitter)</div> </section> <div class="shareline"> <a class="facebook i-facebook addthis_button_facebook" href="http://www.facebook.com/sharer.php?u=https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on facebook</a> <a class="twitter i-twitter addthis_button_twitter" href="https://twitter.com/intent/tweet?text=John McCain Rivals George W. Bush, Barack Obama Honor Hero Who Frustrated, Made Them Better&url=https://www.christianpost.com/news/john-mccain-funeral-george-w-bush-barack-obama-honor-hero-frustrated-made-them-better-227132" target="new"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share on twitter</a> <div class="dropdown"><span class="i-plus"></span> <div class="dd-content"> <h4>Share</h4> <ul> <li><a class="email i-email addthis_button_email"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Email</a></li> <li><a href="print.html" class="print i-print">Print</a></li> <li><a class="facebook i-facebook-alt addthis_button_facebook"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Share</a></li> <li><a class="twitter i-twitter addthis_button_twitter"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Tweet</a></li> <li><a class="pinterest i-pinterest addthis_button_pinterest_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Pin</a></li> <li><a class="linkedin i-linkedin-square addthis_button_linkedin"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Linkedin</a></li> <li><a class="google-plus i-google-plus addthis_button_google_plusone_share"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Google+</a></li> <li><a class="reddit i-reddit addthis_button_reddit"><img src="data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs%3D">Reddit</a></li> </ul> <!-- <section><form action="//christianpost.us11.list-manage.com/subscribe/post?u=673ab5585713f3c683523744e&amp;id=061f5f47a6" method="post" class="newsletter-box" target="_blank"><p>Free sign up cp newsletter!</p><div class="inner"><input type="email" name="EMAIL" class="user-email " id="mce-EMAIL" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_673ab5585713f3c683523744e_061f5f47a6" tabindex="-1" value=""></div><button type="submit" name="subscribe" id="mc-embedded-subscribe">Sign up</button></div></form></section> --> </div> </div> </div> </article> <div class="comment"></div> </div> <div class="sidebar"> <section> <header class="heading-line">Most Popular</header> <ul class="has-right-media graybox"> <li> <div class="media-body"><a href="/news/pastor-andrew-stoecklein-was-inside-church-when-he-attempted-suicide-police-reveal-227075/">Pastor Andrew Stoecklein Was Inside Church When He Attempted Suicide, Police Reveal</a></div> <figure> <a href="/news/pastor-andrew-stoecklein-was-inside-church-when-he-attempted-suicide-police-reveal-227075/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132714/138-86-50/andrew-stoecklein.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/campaign-seeks-to-raise-500000-for-family-of-pastor-andrew-stoecklein-after-suicide-227103/">Campaign Seeks to Raise $500,000 for Family of Pastor Andrew Stoecklein After Suicide</a></div> <figure> <a href="/news/campaign-seeks-to-raise-500000-for-family-of-pastor-andrew-stoecklein-after-suicide-227103/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132719/138-86-50/andrew-stoecklein.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/lauren-daigle-says-her-new-album-will-explain-why-she-lost-her-religion-227119/">Lauren Daigle Says Her New Album Will Explain Why She Lost Her Religion, Embraced Joy of Faith</a></div> <figure> <a href="/news/lauren-daigle-says-her-new-album-will-explain-why-she-lost-her-religion-227119/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/98739/138-86-50/img.png"></a> </figure> </li> <li> <div class="media-body"><a href="/news/paula-white-gives-trump-bible-signed-by-evangelical-leaders-during-white-house-dinner-227062/">Paula White Gives Trump Bible Signed by Evangelical Leaders During White House Dinner</a></div> <figure> <a href="/news/paula-white-gives-trump-bible-signed-by-evangelical-leaders-during-white-house-dinner-227062/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132705/138-86-50/paula-white-jared-kushner-evangelical-dinner.jpg"></a> </figure> </li> <li> <div class="media-body"><a href="/news/john-macarthur-says-he-doesnt-know-any-authentic-evangelical-church-where-racism-is-a-problem-227084/">John MacArthur Says He Doesn't Know Any Authentic Evangelical Church Where Racism Is a Problem</a></div> <figure> <a href="/news/john-macarthur-says-he-doesnt-know-any-authentic-evangelical-church-where-racism-is-a-problem-227084/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/70589/138-86-50/img.jpg"></a> </figure> </li> </ul></section><section> <header class="heading-line">MUST READ</header> <ul class="has-right-media graybox"> <li> <div class="media-body"><a href="/news/isolated-world-pastors-churches-mum-clergy-suicides-220763/">In Isolated World of Pastors, Churches Mum on Troubling Clergy Suicides</a></div> <figure> <a href="/news/isolated-world-pastors-churches-mum-clergy-suicides-220763/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/128878/138-86/clayton-jennings.jpg" alt="clayton-jennings" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/christian-genocide-nigeria-searching-for-truth-amid-the-bloodshed-226959/">A Christian Genocide on the World's Most Christian Continent: Searching for Truth Amid the Bloodshed</a></div> <figure> <a href="/news/christian-genocide-nigeria-searching-for-truth-amid-the-bloodshed-226959/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132650/138-86/school-in-nigeria.jpg" alt="school-in-nigeria" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/beautifully-broken-michael-w-smith-recounts-nervous-breakdown-where-jesus-rescued-him-226881/">'Beautifully Broken': Michael W. Smith Recounts Nervous Breakdown Where Jesus Rescued Him</a></div> <figure> <a href="/news/beautifully-broken-michael-w-smith-recounts-nervous-breakdown-where-jesus-rescued-him-226881/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132637/138-86/michael-w-smith-beautifully-broken.png" alt="michael-w-smith-beautifully-broken" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/deaf-shepherd-pastor-born-hearing-loss-scott-blanchard-michigan-226868/">The Deaf Shepherd: How Pastor Born With Hearing Loss Is Making a Difference in Michigan</a></div> <figure> <a href="/news/deaf-shepherd-pastor-born-hearing-loss-scott-blanchard-michigan-226868/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/132600/138-86/lakepointe-church.jpg" alt="lakepointe-church" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> <li> <div class="media-body"><a href="/news/creator-of-when-calls-the-heart-explains-why-series-is-a-hit-christian-audiences-226772/">'When Calls the Heart' Co-Creator Explains Why Series Is a Hit With Christian Audiences</a></div> <figure> <a href="/news/creator-of-when-calls-the-heart-explains-why-series-is-a-hit-christian-audiences-226772/"><img src="https://cdn6-thechristianpost.netdna-ssl.com/full/95539/138-86/img.jpg" alt="" width="138" height="86" mxw="138" mxh="86"></a> </figure> </li> </ul></section><section class="sponsored-articles"><header class="heading-line">Sponsored Content</header><ul class="has-right-media graybox"><li><div class="media-body"><a href="/sponsored/5-best-reasons-to-go-back-to-school-now.html">5 Best Reasons to Go Back to School Now</a></div><figure><a href="/sponsored/5-best-reasons-to-go-back-to-school-now.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/78_a_138_86.jpg?0804476001533055149" alt="5 Best Reasons to Go Back to School Now" width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/vocational-ministry-how-to-use-every-gift-to-glorify-god.html">Vocational Ministry: How to Use Every Gift to Glorify God </a></div><figure><a href="/sponsored/vocational-ministry-how-to-use-every-gift-to-glorify-god.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/82_a_138_86.jpg?0849115001533055149" alt="Vocational Ministry: How to Use Every Gift to Glorify God " width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/ethics-in-the-workplace-5-ways-to-honor-christ-from-cubicle-to-boardroom.html">Ethics in the Workplace: 5 Ways to Honor Christ from Cubicle to Boardroom </a></div><figure><a href="/sponsored/ethics-in-the-workplace-5-ways-to-honor-christ-from-cubicle-to-boardroom.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/80_a_138_86.jpg?0867599001533055149" alt="Ethics in the Workplace: 5 Ways to Honor Christ from Cubicle to Boardroom " width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/is-christian-education-still-relevant-4-reasons-to-consider-a-faith-based-education.html">Is Christian Education Still Relevant? 4 Reasons to Consider a Faith-Based Education</a></div><figure><a href="/sponsored/is-christian-education-still-relevant-4-reasons-to-consider-a-faith-based-education.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/81_a_138_86.jpg?0885082001533055149" alt="Is Christian Education Still Relevant? 4 Reasons to Consider a Faith-Based Education" width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/teacher-shortage-crisis-why-an-advanced-degree-in-education-makes-a-big-difference.html">Teacher Shortage Crisis: Why an Advanced Degree in Education Makes a Big Difference</a></div><figure><a href="/sponsored/teacher-shortage-crisis-why-an-advanced-degree-in-education-makes-a-big-difference.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/79_a_138_86.jpg?0930898001533055149" alt="Teacher Shortage Crisis: Why an Advanced Degree in Education Makes a Big Difference" width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/faith-and-healthcare-is-there-still-time-for-compassion-in-todays-fast-paced-medical-environments.html">Faith and Healthcare: Is There Still Time for Compassion in Today's Fast-Paced Medical Environments? </a></div><figure><a href="/sponsored/faith-and-healthcare-is-there-still-time-for-compassion-in-todays-fast-paced-medical-environments.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/83_a_138_86.jpg?0952253001533055149" alt="Faith and Healthcare: Is There Still Time for Compassion in Today&amp;#039;s Fast-Paced Medical Environments? " width="138" height="86" /></a></figure></li><li><div class="media-body"><a href="/sponsored/excellence-with-integrity-four-reasons-why-how-you-do-your-job-matters.html">Excellence with Integrity: Four Reasons Why How You Do Your Job Matters </a></div><figure><a href="/sponsored/excellence-with-integrity-four-reasons-why-how-you-do-your-job-matters.html"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/images/cache/thumbnail/0/00/84_a_138_86.jpg?0983422001533055149" alt="Excellence with Integrity: Four Reasons Why How You Do Your Job Matters " width="138" height="86" /></a></figure></li></ul></section><!--ok--> </div> </div> </div> <div id="infinite_container"></div><script src="https://unpkg.com/infinite-scroll@3/dist/infinite-scroll.pkgd.min.js"></script><script type="text/javascript"> var nextPages = [ { "slug": "\/article\/infinite\/lifelong-episcopalian-senator-john-mccain-remembered-hero-stood-quietly-faith-227024\/", "title": "Lifelong Episcopalian Senator John McCain Remembered as 'Hero' Who Stood Quietly for His Faith" }, { "slug": "\/sponsored\/need-an-upgrade-heres-why-you-should-consider-a-career-in-cybersecurity.html?load=infinite", "title": "Need a Job Upgrade? Here's Why You Should Consider a Career in Cybersecurity" }, { "slug": "\/article\/infinite\/john-mccain-doesnt-want-trump-funeral-obama-eulogist-instead-223721\/", "title": "John McCain Doesn't Want Trump at His Funeral, Wants Obama as Eulogist Instead" }
]; var infContainer = jQuery('#infinite_container').infiniteScroll({ path: function() { /*return 'https://www.christianpost.com/sponsored/' + nextPages[this.loadCount].slug + '.html?load=infinite';*/ /*return nextPages[this.loadCount].slug;*/ if (typeof(nextPages[this.loadCount]) == 'undefined') { return false; } else { return nextPages[this.loadCount].slug; } }, append: ".infinite_container", history:'replace', scrollThreshold: 1, prefill: false }); (function () { if ( typeof window.CustomEvent === "function" ) return false; function CustomEvent ( event, params ) { params = params || { bubbles: false, cancelable: false, detail: undefined }; var evt = document.createEvent( 'CustomEvent' ); evt.initCustomEvent( event, params.bubbles, params.cancelable, params.detail ); return evt; } CustomEvent.prototype = window.Event.prototype; window.CustomEvent = CustomEvent; })(); infContainer.on( 'append.infiniteScroll', function( event, response, path, items ) { var doc_root_id = 'inf-scroll-doc-root-' + infContainer.data('infiniteScroll').loadCount; items[0].id = doc_root_id; var parser = document.createElement('a'); parser.href = path; var dlData = { }; dlData = JSON.parse(items[0].dataset.dataLayer); dlData['event'] = 'append.infiniteScroll'; dlData['load_count'] = infContainer.data('infiniteScroll').loadCount; dlData['doc_root_id'] = doc_root_id; dlData['canonical_url'] = parser.origin + parser.pathname; dlData['canonical_path'] = parser.pathname; dataLayer.push(dlData); });</script> <footer class="site-footer container"> <nav class="links"> <div class="logo item"> <a href="https://www.christianpost.com" > <!--[if (!IE 8)&(!IE 7)]><!--><img src="//g-4cf9.kxcdn.com/cp/img/logo.svg" alt="The Christian Post"> <!--<![endif]--> <!--[if (IE 8)&!(IEMobile)]><img src="//g-4cf9.kxcdn.com/cp/img/logo.png" alt="The Christian Post"><![endif]--> </a></div> <ul class="primary"> <li><a href="/aboutus/">About Us</a></li> <li><a href="/aboutus/contact/">Contact Us</a></li> <li><a href="/services/christian-advertising/">Media Kit</a></li> <li><a href="/archive">Archives</a></li> <li><a href="/aboutus/corrections/">Corrections</a></li> <li><a href="/aboutus/general/">Disclaimer</a></li> <li><a href="http://ww2.christianpost.com/aboutus/jobs.html">Careers</a></li> </ul> <ul> <li><a href="/aboutus/terms/">Terms</a></li> <li><a href="/aboutus/privacy/">Privacy policy</a></li> </ul> </nav> <div class="footbar"> <div class="copyright">&copy; 2018 The Christian Post , INC. All Rights Reserved.</div> <div class="cmci">The Christian Post is part of <a href="http://www.cmcigroup.com/" target="_blank">CMC <span class="cmci-logo"></span></a></div> </div></footer> <script src="//g-4cf9.kxcdn.com/cp/js/script.js"></script><!-- Quantcast Tag --><script type="text/javascript">var _qevents = _qevents || [];
(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();
_qevents.push({
qacct:"p-f3_tFTzTnk8n2"
});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-f3_tFTzTnk8n2.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!-- End Quantcast tag --><!--chartbeat--><!-- <script type="text/javascript">var _sf_async_config={uid:24907,domain:"christianpost.com"};
(function(){ function loadChartbeat() { window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") + "js/chartbeat.js"); document.body.appendChild(e); } var oldonload = window.onload; window.onload = (typeof window.onload != 'function') ? loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();</script> --><!--chartbeat--><script src="//g-4cf9.kxcdn.com/track.js"></script><script>(function(){ if (window.ab) {return;} page_count('cp','227132','80','116');add_pixel('227132','682', 'cp', 'www' );
})();</script><script async defer src="//platform.instagram.com/en_US/embeds.js"></script></div></body></html>