<!DOCTYPE html><html class="no-script" lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="https://www.facebook.com/2008/fbml" ><head itemscope itemtype="https://schema.org/WebSite"><title>Dog the bounty hunter sings 'Amazing Grace' on 'The Mask Singer' | Entertainment News</title><meta name="keywords" content="Duane Chapman, Dog the Bounty Hunter, The Masked Singer, Amazing Grace, hymn"><meta name="description" content="Duane Chapman, better known as Dog the Bounty Hunter departed from his typical tough-guy image to put on a costume in the latest season of “The Masked Singer” and before being voted off the show he shared a tearful rendition of “Amazing Grace.”"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.christianpost.com/assets/img/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" href="https://cdn.christianpost.com/assets/img/favicons/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="https://cdn.christianpost.com/assets/img/favicons/favicon-16x16.png" sizes="16x16"><link rel="manifest" href="/assets/img/favicons/manifest.json"><link rel="mask-icon" href="https://cdn.christianpost.com/assets/img/favicons/safari-pinned-tab.svg" color="#2577cf"><link rel="shortcut icon" href="https://cdn.christianpost.com/assets/img/favicons/favicon.ico"><meta name="msapplication-config" content="/assets/img/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><meta name="HandheldFriendly" content="True"><meta name="MobileOptimized" content="320"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta property="fb:pages" content="41093998634" /><meta property="og:ttl" content="2419200" /><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="facebook-domain-verification" content="j68jf4grzfp57oqi4w2kcizgc7d6m9" /><meta name="msvalidate.01" content="2770D3F1DEB25A5BF965224150B525F4" /><meta name="google-site-verification" content="jUJZk866mtO5Gxkt7Qz98Q6XIzxevyn3ngdiSJLpP34" /><meta property="og:site_name" content="The Christian Post" /> <script type="text/javascript" src="//d15lxwsio1b0qb.cloudfront.net/script.js"></script> <link rel="preconnect" href="https://cdn.christianpost.com/" /><link rel="preconnect" href="https://www.googletagmanager.com" /><link rel="preconnect" href="https://static-cdn.spot.im" /><link rel="preconnect" href="https://launcher.spot.im" /><link rel="preconnect" href="https://launcher.spot.im" /><link rel="dns-prefetch" href="https://cdn.christianpost.com/" /><link rel="dns-prefetch" href="https://www.googletagmanager.com" /><link rel="dns-prefetch" href="https://static-cdn.spot.im" /><link rel="dns-prefetch" href="https://open-api.spot.im" /><link rel="dns-prefetch" href="https://launcher.spot.im" /> <script>-1!==location.search.indexOf("abspl=ZmJ2aXJhbA")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","ZmJ2aXJhbA","; path=/;"].join(""));-1!==location.search.indexOf("abspl=b3V0YnJhaW4")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","b3V0YnJhaW4","; path=/;"].join(""));!function(){var a=location.href;var p=function(){var i,t={},s=/=/.test(a),n=(s?a:location.search.substring(1)).split("&");-1!==location.search.indexOf("abspl=YmluZ2Fkcw")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","YmluZ2Fkcw","; path=/;"].join(""));for(p in n)i=n[p].split("="),t[i[0]]=i[1];return!a||s?t:t[a]}();p&&p.absid&&(document.cookie=["absid","=",p.absid,"; path=/;"].join(""));p&&p.abcid&&(document.cookie=["abcid","=",p.abcid,"; path=/;"].join(""));}();</script><script>!function(){var a,b,c,d,e,f,g,h,i,j,k="cssc",l=new Date,m=new Date;return m.setDate(1),m.setMonth(m.getMonth()-1),a=k+l.getYear()+l.getMonth(),b=k+m.getYear()+m.getMonth(),c=function(a,b){var c=[a,"=",JSON.stringify(b),"; path=/;expires="+new Date(Date.now()+5184e6).toGMTString()].join("");document.cookie=c},d=function(a,b,c){var d=document.cookie.match(new RegExp(a+"=([^;]+)"));return d?(d=JSON.parse(d[1]),d||0):(d=document.cookie.match(new RegExp(b+"=([^;]+)")))?(d=JSON.parse(d[1]),Math.floor((d||0)/2)):(d=document.cookie.match(new RegExp(a+"=([^;]+)")),d&&(d=JSON.parse(d[1])),d||0)},e=function(a){var b;return b=a.indexOf("://")>-1?a.split("/")[2]:a.split("/")[0],b=b.split(":")[0]},f=d(a,b,k),g=function(){var a=0,b=36,c=(new Date).getHours(),d=(new Date).getDay();(c>19||c<7||Math.random()<.5&&12==c)&&(a=9999),0!=d&&6!=d||(a=9999),window.spSampleMarker=!(f>=a),Math.random()<.7&&f>=b&&(window.spSampleMarker=!0),window.spSampleMarkerScore=f},location.href===document.referrer?void g():(h=function(){return this._score},i=function(b){f+=b,f>=9999&&(f-=1e3),c(a,f)},j=0,"en-US"!==navigator.language&&(j-=1),document.referrer?"/"===location.pathname&&(document.referrer.includes("google")||document.referrer.includes("yahoo")||document.referrer.includes("bing")||document.referrer.includes("baidu"))?j+=5:location.hostname===e(document.referrer)||(j-=6):j+=7,i(j),void g())}();</script><script>window.cmc_ab_test = Math.floor(Math.random() * 4);</script><script>window.ab = document.referrer.indexOf('/tv/') !== -1 && document.referrer.indexOf(location.hostname) !== -1; window.abok = (document.cookie.indexOf('abok=1') !== -1); if(window.abok){window.ab=true;}; window.ab && (window.spSampleMarker=!0); var gc = function(n) { parts = ("; " + document.cookie).split("; "+n+"="); if (parts.length == 2) return parts.pop().split(";").shift(); }; window.abspl = gc('abspl'); window.absid = gc('absid'); window.abcid = gc('abcid'); window.arcnt = parseInt(gc('cmc_arcnt'))||0;</script> <script>
    dataLayer = [{"_":"_","page_type":"articles","category":["entertainment"],"article_id":"247805","article_title":"Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'","article_keywords":"Duane Chapman, Dog the Bounty Hunter, The Masked Singer, Amazing Grace, hymn","article_type":"n","reporter":"jeannie-law","slideshow":false}];
    !function(t,e){t[e]=t[e]||[],t[e].push({"gtm.start":(new Date).getTime(),event:"gtm.js"})}(window,"dataLayer");
</script> <script async="async" src="https://www.googletagmanager.com/gtm.js?id=GTM-M3XGPPX"></script> <script>
    var base_url   = "/";
    var cp_domain  = "www.christianpost.com";
    var static_url = "https://cdn.christianpost.com/";
    const isCustomerSession = false;
    const role = "guest";
    const spotim_id = "sp_BCbDgHvV";
    var html = document.documentElement;
    html.className = html.className.replace('no-script', 'has-script');
</script> <script data-rh="true" type="application/ld+json">
    {
        "@context":"http://schema.org",
        "@type":"NewsMediaOrganization",
        "name":"The Christian Post",
        "alternateName": "CP",
        "logo":{
            "@context":"http://schema.org",
            "@type":"ImageObject",
            "url":"https://cdn.christianpost.com/assets/img/logo.png",
            "height":28,"width":559
        },
        "address": {
            "@type": "PostalAddress",
            "addressCountry": "US",
            "addressLocality": "Washington",
            "addressRegion": "District of Columbia",
            "postalCode": "20011"
        },
        "url":"https://www.christianpost.com/",
        "diversityPolicy":"https://www.christianpost.com/privacy-policy.html",
        "ethicsPolicy":"https://www.christianpost.com/editorial-policy.html",
        "masthead":"https://www.christianpost.com/leadership.html",
        "sameAs":[
            "https://www.facebook.com/ChristianPost.Intl",
            "https://twitter.com/ChristianPost",
            "https://www.instagram.com/christianpostintl",
            "https://www.youtube.com/user/TheChristianpost",
            "https://www.linkedin.com/company/the-christian-post",
            "https://www.wikidata.org/wiki/Q9684",
            "https://www.reddit.com/domain/christianpost.com",
            "https://en.wikipedia.org/wiki/The_Christian_Post"
        ]
    }
</script> <link rel="subresource" href="https://cdn.christianpost.com/assets/css/main.css"><link rel="stylesheet" href="https://cdn.christianpost.com/assets/css/main.css"><link rel="stylesheet" href="https://cdn.christianpost.com/assets/css/brand-solutions.css"> <script>
                            var tracking_pix = '/statistics/pixel/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpYXQiOjE2NTA0NDI3MDMsImV4cCI6MTY1MDQ0MjcwOCwiaWQiOiIyNDc4MDUiLCJ0eXBlIjoibmV3cyIsInJlcG9ydGVyX2lkIjoxNzExLCJhdXRob3JfaWQiOiI0MjQiLCJyZWZmZXIiOiIiLCJjYXRlb2dyeV9pZCI6IjExIn0.ji5USNzKevZj3ngMwRHEu8cJ5OAd1ET7PVhmXm-juoI.gif'
                                        var ias_urls  = ["/news/dog-the-bounty-hunter-never-doubted-god-after-wifes-death.html","/sponsored/get-a-good-ranchers-box-of-usda-graded-100-american-meat-and-save-up-to-25.html","/news/dog-the-bounty-hunter-and-fiancee-visit-colorado-church.html","/sponsored/shannon-bream-ukrainian-womens-courage-reminds-me-of-the-mother-of-jesus.html"];
                                        let isCommentDisabled = false;
                    </script> <link rel="amphtml" href="https://www.christianpost.com/amp/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html"><meta property="article:published_time" content="2022-04-20T00:42:16-04:00"><meta property="og:url" content="https://www.christianpost.com/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html" /><meta property="og:type" content="website" /><meta property="og:title" content="Dog the Bounty Hunter sings emotional rendition of &#039;Amazing Grace&#039; on &#039;The Mask Singer&#039;" /><meta property="og:description" content="Duane Chapman, better known as Dog the Bounty Hunter departed from his typical tough-guy image to put on a costume in the latest season of “The Masked Singer” and before being voted off the show he shared a tearful rendition of “Amazing Grace.”" /><meta property="og:image" content="https://cdn.christianpost.com/files/original/thumbnail/24/78/247805.jpg" /><meta property="fb:pages" content="41093998634"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@ChristianPost"><meta name="twitter:creator" content="@ChristianPost"><meta name="twitter:title" content="Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'"><meta name="twitter:description" content="Duane Chapman, better known as Dog the Bounty Hunter departed from his typical tough-guy image to put on a costume in the latest season of “The Masked Singer” and before being voted off the show he shared a tearful rendition of “Amazing Grace.”"><meta name="twitter:image" content="https://cdn.christianpost.com/files/original/thumbnail/24/78/247805.jpg"><link rel="canonical" href="https://www.christianpost.com/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html"> <script type="application/ld+json">
    {
      "@context": "https://schema.org",
      "@type": "NewsArticle",
      "mainEntityOfPage": "https://www.christianpost.com/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html",
      "url": "https://www.christianpost.com/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html",
              "keywords":["Duane Chapman"," Dog the Bounty Hunter"," The Masked Singer"," Amazing Grace"," hymn"],
            "headline": "Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'",
      "datePublished": "2022-04-20T00:42:16-04:00",
      "dateModified":  "2022-04-20T02:22:49-04:00",
      "description":   "Duane Chapman, better known as Dog the Bounty Hunter departed from his typical tough-guy image to put on a costume in the latest season of “The Masked Singer” and before being voted off the show he shared a tearful rendition of “Amazing Grace.”",
             "author": {
            "@context":"http://schema.org",
            "@type": "Person",
            "url":"https://www.christianpost.com/by/jeannie-law",
            "name": "Jeannie Ortega Law"
       },
       "creator":"Jeannie Ortega Law",
              "image": {
            "@type":"ImageObject",
            "url":"https://cdn.christianpost.com/files/original/thumbnail/24/78/247805.jpg" 
        },
       "publisher": {
            "@type":"NewsMediaOrganization",
            "@id":"https://www.christianpost.com",
            "name":"The Christian Post",
            "logo": {
                "@type":"ImageObject",
                "url":"https://www.christianpost.com/assets/img/logo.png",
                "width":559,
                "height":28
            }
        },
                   "articleSection":"Entertainment",
               "inLanguage": "en"
    }
  </script> <script src="https://launcher.spot.im/spot/sp_BCbDgHvV" type="text/javascript" data-spotim-module="spotim-launcher" async ></script> </head><body class="normal-version article-page"><header class="site-header-container " role="banner"><div class="site-header fixed-header" aria-hidden="true"><div class="container"><div class="headbar"><div class="tools" aria-hidden="true"><a class="logo-abbr" href="/"><img src="/assets/img/cp.svg" alt="The Christian Post" width="52" height="22"></a><button class="nav-toggle mobile-only" data-js-toggle=".offcanvas"><span class="i-nav"><span></span></span></button><button class="nav-toggle desktop-only" data-js-toggle="#main-nav"><span class="i-nav"><span></span></span></button><button class="search-toggle" data-js-toggle="#main-search"><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span><span class="visually-hidden">Search</span></button></div><div class="headbar-main" aria-hidden="true"><div class="header-page-title">Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'</div></div><div class="desktop-only" style="float:right;"><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html">Subscribe</a></div></div></div></div></div><p class="visually-hidden">The Christian Post</p><a href="#main" class="skip-link visually-hidden">Skip to main content</a><noscript><p class="enable-js"> To enjoy our website, you'll need to enable <b>JavaScript</b> in your web browser. Please <a href="http://enable-javascript.com/" target="_blank"><b>click here</b></a> to learn how. </p></noscript><!--[if lt IE 9]><p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/" target="_blank">upgrade your browser</a> to improve your experience.</p><![endif]--><div class="offcanvas" id="offcanvas"><div class="container"><button class="btn-close mobile-only" data-js-toggle="#offcanvas" aria-hidden="true"><span class="i-close"><span></span></span></button></div><div class="container"><nav class="main-nav" id="main-nav" role="navigation" aria-label="Main Navigation"><button class="btn-close desktop-only" data-js-toggle="#main-nav" aria-hidden="true"><span class="i-close"><span></span></span></button><ul id="cp_header_menu"><li class=" "><a href="/" class="link">Home</a></li><li class=" "><a href="/news" class="link">Latest News</a></li><li class=" "><a href="/category/church-ministries" class="link">Church &amp; Ministries</a></li><li class=" "><a href="/category/us" class="link">U.S.</a></li><li class=" "><a href="/category/world" class="link">World</a></li><li class=" "><a href="/category/politics" class="link">Politics</a></li><li class=" "><a href="/category/entertainment" class="link">Entertainment</a></li><li class=" "><a href="/category/living" class="link">Living</a></li><li class=" "><a href="/opinion" class="link">Opinion</a></li><li class=" "><a href="/business" class="link">Business</a></li><li class=" "><a href="/sports" class="link">Sports</a></li><li class=" "><a href="/education" class="link">Education</a></li><li class=" "><a href="/lifestyle" class="link">Lifestyle</a></li><li class=" "><a href="/shopping" class="link">Shopping</a></li><li class=" "><a href="/books" class="link">Books</a></li><li class=" "><a href="/church-resource" class="link">Church Resource</a></li><li class=" "><a href="/video" class="link">Video</a></li><li class=" "><a href="/podcast" class="link">Christian Podcasts</a></li><li class=" "><a href="/magazine" class="link">CP Magazine</a></li><li class="link-topics" id="topics"><a href="/topic" class="link">Christian Topics</a></li><li class="has-subnav "><a class="link" href="https://www.christianpost.com/sponsored/branded-content">Brand Solutions</a></li><li class="cp-menu last"><a href="/jobs.html" class="link">Job Board</a></li></ul></nav><div class="edition"><span><strong>Edition</strong></span><span class="current"><span class="visually-hidden">Current Edition: </span>English</span><a class="link" href="https://spanish.christianpost.com/" target="_blank">Español</a><a class="link" href="https://chinese.christianpost.com/" target="_blank">中文</a><a class="switch-link" href="/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html?mobile=true">Switch to Modern Version</a></div></div></div><form class="main-search search-form" id="main-search" action="/search" method="get" aria-label="Main Search Field" ><div class="container" role="search"><div class="search-container"><div class="visually-hidden" role="alert" aria-relevant="all"></div><input id="main-search-input" type="search" name="s" placeholder="Search" aria-label="Search"><button class="btn-submit"><span class="visually-hidden">Go</span><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span></button></div><button class="btn-close" data-js-toggle="#main-search" aria-hidden="true"><span class="i-close"><span></span></span></button></div></form><div class="site-header"><div class="container"><div class="headbar"><div class="tools" aria-hidden="true"><button class="nav-toggle mobile-only" data-js-toggle=".offcanvas"><span class="i-nav"><span></span></span></button><button class="nav-toggle desktop-only" data-js-toggle="#main-nav"><span class="i-nav"><span></span></span></button><button class="search-toggle" data-js-toggle="#main-search"><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span><span class="visually-hidden">Search</span></button></div><div class="headbar-main" aria-hidden="true"><div class="branding" id="branding"><a href="/"><img src="/assets/img/logo.svg" alt="Go to Homepage" width="595" height="31"></a></div></div><div class="desktop-only" style="float:right;"><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html">Subscribe</a></div></div></div></div><div class="dateline-mb mobile-only"><div class="container"><time style="float: left; padding-top: 10px; " class="today" datetime="Wednesday, Apr 20, 2022">Wednesday, Apr 20, 2022</time><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html">Subscribe</a></div></div></div></div></header> <script type="text/javascript" src="https://cdn.christianpost.com/vendor/js/jquery-1.11.0.min.js"></script> <script type="text/javascript" src="https://cdn.christianpost.com/vendor/jquery-cookie/jquery.cookie.js"></script> <main id="main" role="main" tabindex="-1"><section class="topbar-news-wrapper" data-click-type="topbar-news"><h2 class="visually-hidden">Recommended</h2><div class="inner"><ul class="img-on-left topbar-news slider-fallback"><li><a href="/news/twitter-threatens-to-ban-news-outlet-over-photo-of-illegal-full-term-abortion.html"><img src="https://cdn.christianpost.com/files/cache/image/14/48/144822_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/twitter-threatens-to-ban-news-outlet-over-photo-of-illegal-full-term-abortion.html">Twitter threatens news outlet with ‘permanent ban’ for showing photo of baby illegally aborted</a></h3></li><li><a href="/news/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html"><img src="https://cdn.christianpost.com/files/cache/image/8/05/80581_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html">Alice Cooper talks Heaven, Hell and Satan: I wake up, grab coffee and read my Bible</a></h3></li><li><a href="/news/pastor-stovall-weems-steps-down-from-celebration-church.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/77/247796_a_66_66_429_150.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/pastor-stovall-weems-steps-down-from-celebration-church.html">Pastor Stovall Weems steps down from Celebration Church after filing lawsuit</a></h3></li><li><a href="/news/pastor-josh-kimes-allegedly-admitted-to-writing-racist-text.html"><img src="https://cdn.christianpost.com/files/cache/image/14/50/145013_a_66_66.png" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/pastor-josh-kimes-allegedly-admitted-to-writing-racist-text.html">Former Hillsong Boston Pastor Josh Kimes allegedly admitted to writing racist text to colleagues</a></h3></li><li><a href="/voices/the-golden-state-has-become-the-gangrene-state.html"><img src="https://cdn.christianpost.com/files/cache/image/14/39/143934_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/the-golden-state-has-become-the-gangrene-state.html">The Golden State has become the 'Gangrene State'</a></h3></li><li><a href="/voices/from-is-god-dead-in-1966-to-give-up-god-today.html"><img src="https://cdn.christianpost.com/files/cache/image/12/29/122935_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/from-is-god-dead-in-1966-to-give-up-god-today.html">From Time’s 'Is God dead?' in 1966 to The New York Times’ call to 'Give Up God' today</a></h3></li><li><a href="/voices/a-zero-star-review-for-yelps-abortion-activism.html"><img src="https://cdn.christianpost.com/files/cache/image/14/16/141659_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/a-zero-star-review-for-yelps-abortion-activism.html">A zero star review for Yelp’s abortion activism</a></h3></li><li><a href="/voices/the-myth-of-a-balanced-life-retreating-from-or-retreating-to.html"><img src="https://cdn.christianpost.com/files/cache/image/14/17/141728_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/the-myth-of-a-balanced-life-retreating-from-or-retreating-to.html">The myth of a balanced life: Retreating from or retreating to</a></h3></li><li><a href="/voices/the-bigger-issue-behind-the-what-is-a-woman-question.html"><img src="https://cdn.christianpost.com/files/cache/image/14/49/144993_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/the-bigger-issue-behind-the-what-is-a-woman-question.html">The bigger issue behind the 'What is a woman?' question</a></h3></li><li><a href="/voices/warner-bros-wont-say-gay-in-china.html"><img src="https://cdn.christianpost.com/files/cache/image/14/49/144989_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/warner-bros-wont-say-gay-in-china.html">Warner Bros. won’t say gay in China</a></h3></li></ul></div></section><div class="article-cell" data-data-layer="{&quot;_&quot;:&quot;_&quot;,&quot;page_type&quot;:&quot;articles&quot;,&quot;category&quot;:[&quot;entertainment&quot;],&quot;article_id&quot;:&quot;247805&quot;,&quot;article_title&quot;:&quot;Dog the Bounty Hunter sings emotional rendition of &#039;Amazing Grace&#039; on &#039;The Mask Singer&#039;&quot;,&quot;article_type&quot;:&quot;n&quot;,&quot;reporter&quot;:&quot;jeannie-law&quot;,&quot;r_id&quot;:1711,&quot;slideshow&quot;:false,&quot;a_id&quot;:&quot;424&quot;}"><div class="container"><div class="sec-line breadcrumbs"><a aria-hidden="true" href="/">CP</a><a href="/category/entertainment"><span class="sec-name" >&nbsp;Entertainment</span> | <time datetime="Wednesday, April 20, 2022" >Wednesday, April 20, 2022</time></a></div><div class="main-layout sticky-layout"><div><article class="full-article" id="article_content"><header><h1 class="article-title">Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'</h1><div class="article-byline has-tools"><div>By <span itemprop="author creator" itemtype="http://schema.org/Person" itemid="/by/jeannie-law"><a class="reporter" href="/by/jeannie-law"><span itemprop="name">Jeannie Ortega Law</span></a></span>, Christian Post Reporter <a class="reporter-twitter" target="_blank" href="https://twitter.com/jlawcp?lang=en"><img src="/assets/img/twitter-color.svg" alt="Twitter" width="24" height="24"></a><time class="visually-hidden"> | Wednesday, April 20, 2022</time></div><div class="article-tools"><a href="#cp-talk" class="talk-cp-247805" data-scrollto=".viafoura" aria-label="Go to comments"><img src="https://cdn.christianpost.com/assets/img/icon/chat-rect.svg" alt=""></a><a href="" aria-label="Read this article for me"><img src="https://cdn.christianpost.com/assets/img/icon/mic.svg" alt=""></a><a href="" class="js-share" aria-label="Share"><img src="https://cdn.christianpost.com/assets/img/icon/share-outline.svg" alt=""></a></div></div></header><figure class="img-box align-center center" itemscope itemtype="https://schema.org/ImageObject"><picture width="760" height="403"><source type="image/webp" srcset="https://cdn.christianpost.com/files/cache/image/14/50/145019_w_760_403.webp"><img src="https://cdn.christianpost.com/files/cache/image/14/50/145019_w_760_403.png" class="type:primaryImage" alt="Dog The Bounty Hunter " width="760" height="403"></source></picture><figcaption class="caption"><span itemprop="description" class="photo-des">YouTube/The Masked Singer</span></figcaption></figure><p>Duane Chapman, better known as Dog the Bounty Hunter, departed from his typical tough-guy image by donning a costume to conceal his identity in this season's “The Masked Singer,” but before being voted off the show, he shared a tearful rendition of “Amazing Grace.”</p><p>Chapman was unmasked earlier this month, but before making his exit he sang a hymn his mother used to sing to him. Dressed as an armadillo, he performed “Amazing Grace” on a double-elimination night.</p><p>Judges Robin Thicke and Nicole Scherzinger were noticeably moved. Thicke even revealed that he sings the Christian hymn to his child every night.</p><p>Chapman and actress Jennifer Holiday, who wore the Miss Teddy costume, were both eliminated following their performances.  </p><p>Although Chapman had no formal training as a singer, he revealed that being a blackbelt helped with his performances on “The Masked Singer.” The premise of the series is that the judges try and guess who is behind the mask by identifying their singing voice and the clues given to them throughout the show.</p><p>“I have a black belt in martial arts. I’ve arrested over 8,000 fugitives, so I’ve kicked a lot of okole [Hawaiian for butt],” the famous bounty hunter told <a href="https://hollywoodlife.com/2022/04/13/dog-the-bounty-hunter-armadillo-the-masked-singer-interview/?msclkid=f4d67acbbc0d11eca597d429f52d9bcd" target="_blank">HollywoodLife</a>. “We, the team and Fox, tried to throw in the songs, in the interview, I presented the shaka — it’s called ‘throw a shaka’ — four or five times. We tried to really load up the detectives and the judges with more info than they’ve ever received.”</p><p>“It’s one of the first times where I got to lay down the clues instead of finding them because that’s what I do, right? And I was like, ‘Oh, I could get away from anybody. This is so much fun.’ I was amazed that I went as long as I did without getting number one, booted, and number two, guessed,” he added.</p><div class="embedded-content" style="margin:0 auto 30px;"><iframe src="https://www.youtube.com/embed/JSgZvfT2vh4" width="640" height="315" frameborder="0" allowfullscreen></iframe></div><p>Chapman, who's known for being outspoken about his faith, intentionally chose to sing “Amazing Grace.”</p><p>“I am trying to be a Christian, so we negotiated a Christian song and that song happened to be my mother’s most favorite. It really was very emotional for me to show my faith,” the reality star added.</p><script src="https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js" pubname="christianpostcom" widgetname="0011r00002XMEVu_11109"></script><p>While dressed as an armadillo, Chapman fell on stage in a previous performance. He said it was his faith in God that helped him persevere.  </p><p>“I don’t know why I fell. I think evil pushed me down because they didn’t want me to sing that song, and they even had to help me out in the chair. That thing (the costume) was over 200 pounds,” Chapman explained. “I couldn’t stand up by myself. So how I ever stood up like that, I know that in my world, the angels grabbed me and said, ‘Get out there.’ So I was petrified.”</p><p>Chapman concluded by saying his wife, Francie, [Frane] had just watched the Olympic skier who jumped a big jump but at the end, she fell.</p><p>“That went right through my mind. I thought you better get up. You’ve been pushed out of life before and you have always stood up. I don’t know what happened. Adrenaline and the Lord took over,” he testified about why he refused to allow the setbacks to discourage him.</p></p><p><div class="article_credit"><p>Jeannie Ortega Law is a reporter for The Christian Post. Reach her at: <a href="mailto:jeannie.law@christianpost.com">jeannie.law@christianpost.com</a> She's also the author of the book, <em><a href="https://www.amazon.com/What-Happening-Me-Defeat-Unseen/dp/0800761766">What Is Happening to Me? How to Defeat Your Unseen Enemy</a> </em>Follow her on Twitter: <a href="https://twitter.com/jlawcp" target="_blank" rel="noopener">@jlawcp</a> Facebook: <a href="https://www.facebook.com/JeannieOMusic" target="_blank" rel="noopener">JeannieOMusic</a></p></div></article><section class="inline-newsletter-oct20 design2 inline-newsletter-campaign" id="eoa_2"><div class="txt-wp"><h2 class="title">Free CP Newsletters</h2><p class="txt">Join over 250,000 others to get the top stories curated daily, plus special offers!</p></div><form method="post" class="newsletter-campaign-form" action="/newsletter/eoa-2.html"><div class="form-newsletter"><input class="input-basic" name="email" type="email" placeholder="Enter your email" required="required"><button class="submit-newsletter-form button-basic submit-eoa-2">Submit</button></div><div role="alert" aria-relevant="all" class="newsletter-message-body"></div></form></section><section class="related-stories col bold" data-click-type="related-articles"><h2 class="col-header">Related Articles</h2><div class="inner"><ul class="related-story-list img-on-left slider-fallback no-bullet"><li><a href="/news/dog-the-bounty-hunter-never-doubted-god-after-wifes-death.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/23/93/239305_a_85_85.png" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/dog-the-bounty-hunter-never-doubted-god-after-wifes-death.html">Dog the Bounty Hunter ‘never doubted’ God after wife’s death; talks spiritual warfare and new film </a></h3></li><li><a href="/news/dog-the-bounty-hunter-and-fiancee-visit-colorado-church.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/19/241978_a_85_85.jpg" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/dog-the-bounty-hunter-and-fiancee-visit-colorado-church.html">Dog the Bounty Hunter and fiancee visit Colorado church, witness ‘powerful move of God’</a></h3></li><li><a href="/news/duane-chapman-diagnosed-with-pulmonary-embolism-hes-a-ticking-time-bomb-says-dr-oz.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/23/32/233203_a_85_85.png" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/duane-chapman-diagnosed-with-pulmonary-embolism-hes-a-ticking-time-bomb-says-dr-oz.html">Duane Chapman diagnosed with pulmonary embolism; he’s a ’ticking time bomb,' says Dr. Oz </a></h3></li><li><a href="/news/christian-star-dog-the-bounty-hunter-searches-for-brian-laundrie.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/50/245069_a_85_85_1083_324.jpg" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/christian-star-dog-the-bounty-hunter-searches-for-brian-laundrie.html">Dog the Bounty Hunter's Christian faith prompts him to join search for Brian Laundrie: spokesperson</a></h3></li></ul></div></section><section class="col bold" data-click-type="sponsored-article-bottom"><h2 class="col-header quiet">Sponsored</h2><ul class="has-divider img-on-left list-col2 at-top"><li><a href="/sponsored/a-story-of-redemption.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/04/466_a_120_80.png?0246404001649256238" alt="A story of redemption" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/a-story-of-redemption.html" rel="sponsored">A story of redemption</a></h3></div></li><li><a href="/sponsored/shannon-bream-ukrainian-womens-courage-reminds-me-of-the-mother-of-jesus.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/04/465_a_120_80.jpg?0247315001649256238" alt="Shannon Bream: Ukrainian women&amp;#039;s courage reminds me of the mother of Jesus" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/shannon-bream-ukrainian-womens-courage-reminds-me-of-the-mother-of-jesus.html" rel="sponsored">Shannon Bream: Ukrainian women's courage reminds me of the mother of Jesus</a></h3></div></li><li><a href="/sponsored/duck-dynasty-star-phil-robertson-offers-blueprint-for-clinging-to-truth-in-a-cancel-culture-ridden-world.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/04/464_a_120_80.png?0247991001649256238" alt="&ldquo;Duck Dynasty&rdquo; Star Phil Robertson Offers Blueprint for Clinging to Truth in a Cancel Culture-Ridden World" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/duck-dynasty-star-phil-robertson-offers-blueprint-for-clinging-to-truth-in-a-cancel-culture-ridden-world.html" rel="sponsored">&ldquo;Duck Dynasty&rdquo; Star Phil Robertson Offers Blueprint for Clinging to Truth in a Cancel Culture-Ridden World</a></h3></div></li><li><a href="/sponsored/does-a-childs-choice-matter.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/04/460_a_120_80.jpg?0248649001649256238" alt="Does a child&rsquo;s choice matter?" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/does-a-childs-choice-matter.html" rel="sponsored">Does a child&rsquo;s choice matter?</a></h3></div></li></ul></section><div data-spotim-module="pitc"></div><div id="cp-talk" class="viafoura" data-spotim-module="conversation" data-post-id="christianpost.com-publication-247805"></div></div><div><section><section class="col bold" data-click-type="most-popular"><h2 class="col-header">Most Popular</h2><article><a href="/news/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html"><img src="https://cdn.christianpost.com/files/cache/image/8/05/80581_a_963_642_7_7.jpg" srcset="https://cdn.christianpost.com/files/cache/image/8/05/80581_a_300_200_7_7.jpg 300w,https://cdn.christianpost.com/files/cache/image/8/05/80581_a_600_400_7_7.jpg 600w,https://cdn.christianpost.com/files/cache/image/8/05/80581_a_963_642_7_7.jpg 963w" sizes="(max-width: 1023px) 100vw, 300px" width="963" height="642"/></a><h3 class="h2"><a class="link" href="/news/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html">Alice Cooper talks Heaven, Hell and Satan: I wake up, grab coffee and read my Bible</a></h3></article><ul class="has-divider img-on-left at-top"><li><a href="/news/the-golden-state-has-become-the-gangrene-state.html"><img src="https://cdn.christianpost.com/files/cache/image/14/39/143934_a_130_72_532_291.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/the-golden-state-has-become-the-gangrene-state.html">The Golden State has become the 'Gangrene State'</a></h3></div></li><li><a href="/news/from-is-god-dead-in-1966-to-give-up-god-today.html"><img src="https://cdn.christianpost.com/files/cache/image/12/29/122935_a_130_72_7_7.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/from-is-god-dead-in-1966-to-give-up-god-today.html">From Time’s 'Is God dead?' in 1966 to The New York Times’ call to 'Give Up God' today</a></h3></div></li><li><a href="/news/pastor-josh-kimes-allegedly-admitted-to-writing-racist-text.html"><img src="https://cdn.christianpost.com/files/cache/image/14/50/145013_a_130_72_7_7.png" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/pastor-josh-kimes-allegedly-admitted-to-writing-racist-text.html">Former Hillsong Boston Pastor Josh Kimes allegedly admitted to writing racist text to colleagues</a></h3></div></li><li><a href="/news/burger-king-apologizes-for-ads-using-jesus-words-at-last-supper.html"><img src="https://cdn.christianpost.com/files/cache/image/4/63/46385_a_130_72_7_7.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/burger-king-apologizes-for-ads-using-jesus-words-at-last-supper.html">Burger King apologizes for 'offensive campaign' using Jesus' words at the Last Supper</a></h3></div></li></ul></section><section class="rightrail-newsletter-oct20 design2" id="rr-2"><div class="heading">The Christian Post Newsletter</div><h2 class="title">Get on the List</h2><p class="txt1"><span>Do you want award-winning journalism with a <span class="nw">Christian worldview</span>, delivered to your inbox?</span></p><form class="newsletter-campaign-form" action="/newsletter/sidebar-bottom.html" method="post"><input class="input-basic" name="email" type="email" placeholder="Enter your email" required="required"><button class="submit-newsletter-form button-basic submit-sidebar-bottom">Submit</button><div role="alert" aria-relevant="all" class="newsletter-message-body"></div></form><p class="txt2">Join over 250,000 others to get the top stories curated daily, plus special offers!</p></section></section><section class="col bold" data-click-type="more-in-section"><h2 class="col-header">More In Entertainment</h2><ul class="has-divider img-on-left in-middle"><li><a href="/entertainment/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/78/247805_a_130_72_586_253.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/entertainment/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html">Dog the Bounty Hunter sings emotional rendition of 'Amazing Grace' on 'The Mask Singer'</a></h3></div></li><li><a href="/entertainment/netflix-fertility-doctor-impregnated-over-50-women.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/78/247800_a_130_72.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/entertainment/netflix-fertility-doctor-impregnated-over-50-women.html">Netflix documentary highlights fertility doctor who used own sperm to impregnate at least 50 women</a></h3></div></li><li><a href="/entertainment/kathie-lee-giffords-new-series-highlights-stories-of-faith.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/77/247774_a_130_72.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/entertainment/kathie-lee-giffords-new-series-highlights-stories-of-faith.html">Kathie Lee Gifford's new series 'The Jesus I Know' highlights celebrity's stories of faith</a></h3></div></li><li><a href="/entertainment/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/77/247781_a_130_72.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/entertainment/alice-cooper-shares-thoughts-on-the-devil-heaven-hell.html">Alice Cooper talks Heaven, Hell and Satan: I wake up, grab coffee and read my Bible</a></h3></div></li><li><a href="/entertainment/dennis-quaids-blue-miracle-wins-most-inspiring-film-of-2021.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/77/247782_a_130_72_397_331.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/entertainment/dennis-quaids-blue-miracle-wins-most-inspiring-film-of-2021.html">Dennis Quaid's 'Blue Miracle' wins most inspiring film of 2021 at Movieguide awards show</a></h3></div></li></ul></section></div></div></div></div><div class="share-widget-wp"><div class="share-widget-backdrop"></div><div class="share-widget"><a class="close bxsh" href="https://www.christianpost.com/news/dog-the-bounty-hunter-sings-amazing-grace-on-the-mask-singer.html" aria-label="Close"><img src="https://cdn.christianpost.com/assets/img/icon/close.svg" alt="X"></a><div class="header"><div class="img"><img src="https://cdn.christianpost.com/assets/img/cp.svg" alt=""></div><p class="title"><span class="line-clamp"></span></p></div><div class="share-widget-main"><div class="general no-bullet"><a class="copy-link js-copy-link" href="" target="_blank" rel="noreferrer"><img src="https://cdn.christianpost.com/assets/img/icon/link.svg" alt=""><span class="txt">Copy link</span></a><a class="email js-email" href="" target="_blank" rel="noreferrer"><img src="https://cdn.christianpost.com/assets/img/icon/email-outline.svg" alt=""><span class="txt">Email</span></a><a class="print js-print" href="" target="_blank" rel="noreferrer"><img src="https://cdn.christianpost.com/assets/img/icon/print-outline.svg" alt=""><span class="txt">Print</span></a></div><div class="social"><a class="facebook" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/facebook.svg" alt=""></span><span class="txt">Facebook</span></a><a class="twitter" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/twitter.svg" alt=""></span><span class="txt">Twitter</span></a><a class="whatsapp" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/whatsapp.svg" alt=""></span><span class="txt">Whatsapp</span></a><a class="linkedin" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/linkedin.svg" alt=""></span><span class="txt">Linkedin</span></a><a class="reddit" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/reddit.svg" alt=""></span><span class="txt">Reddit</span></a><a class="telegram" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/telegram.svg" alt=""></span><span class="txt">Telegram</span></a><a class="pinterest" href="" target="_blank" rel="noreferrer"><span class="icon bxsh"><img src="https://cdn.christianpost.com/assets/img/social/original/pinterest.svg" alt=""></span><span class="txt">Pinterest</span></a></div></div></div></div></main><section class="brands-belt" id="above-footer"><div class="container"><div class="brands-belt-content"><h2 class="title">Group of Brands</h2><a class="brand-logo outline" href="https://www.christiantoday.com" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/christian-today.svg" width="183" height="13" alt="Christian Today"></a><a class="brand-logo outline" href="https://www.crossmap.com" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/crossmap.svg" width="114" height="14" alt="Crossmap"></a><a class="brand-logo outline" href="https://www.bibleportal.com" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/bible-portal.svg" width="126" height="26" alt="Bible Portal"></a><a class="brand-logo outline" href="https://www.breathecast.com" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/breathe-cast.jpg" width="129" height="24" alt="BreatheCast"></a><a class="brand-logo outline" href="https://edifi.app" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/edifi.svg" width="45" height="26" alt="Edifi"></a><a class="brand-logo outline" href="https://www.videpress.com" target="_blank"><img src="https://cdn.christianpost.com/assets/img/brands/vide-press.svg" width="103" height="14" alt="Vide Press"></a></div></div></section><footer class="site-footer" role="contentinfo"><div class="container"><div class="footer-logo-line"><div class="branding" ><a href="/" itemprop="url"><img src="https://cdn.christianpost.com/assets/img/logo.svg" alt="Go to Homepage" width="595" height="31"></a><p class="visually-hidden">The Christian Post</p></div><div class="tools"><a class="btn btn-xs btn-outline uppercase" href="/signup" target="_blank">Subscribe Now <span class="i-arrow"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><path d="M13 2l22 22-22 22" stroke="currentColor" fill="none"/></svg></span></span></a><a class="btn btn-xs btn-fill" href="/contact-us.html">We want to hear from you! <span class="i-arrow"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><path d="M13 2l22 22-22 22" stroke="currentColor" fill="none"/></svg></span></span></a></div></div><nav role="navigation" aria-labelledby="footer-nav-heading"><h2 class="visually-hidden" id="footer-nav-heading">Overall Navigation</h2><div class="nav-layout"><div><h3>Main</h3><ul><li class=" "><a href="/" class="link">Home</a></li><li class=" "><a href="/news" class="link">Latest News</a></li><li class=" "><a href="/category/church-ministries" class="link">Church &amp; Ministries</a></li><li class=" "><a href="/category/us" class="link">U.S.</a></li><li class=" "><a href="/category/world" class="link">World</a></li><li class=" "><a href="/category/politics" class="link">Politics</a></li><li class=" "><a href="/category/entertainment" class="link">Entertainment</a></li><li class=" "><a href="/category/living" class="link">Living</a></li><li class=" "><a href="/opinion" class="link">Opinion</a></li></ul></div><div><h3>SECTIONS</h3><ul><li class=" "><a href="/business" class="link">Business</a></li><li class=" "><a href="/sports" class="link">Sports</a></li><li class=" "><a href="/education" class="link">Education</a></li><li class=" "><a href="/lifestyle" class="link">Lifestyle</a></li><li class=" "><a href="/shopping" class="link">Shopping</a></li><li class=" "><a href="/books" class="link">Books</a></li><li class=" "><a href="/church-resource" class="link">Church Resource</a></li><li class=" "><a href="/video" class="link">Video</a></li><li class=" "><a href="/podcast" class="link">Christian Podcasts</a></li><li class=" "><a href="/magazine" class="link">CP Magazine</a></li><li><a href="/newsletter/daily-newsletter" class="link">Christian Newsletter</a></li></ul></div><div><h3>About Us</h3><ul><li><a class="link" href="/about-us.html">About Us</a></li><li><a class="link" href="/statement-of-faith.html" >Statement Of Faith</a></li><li><a class="link" href="/leadership.html">Leadership</a></li><li><a class="link" href="/general-disclaimer.html" >General Disclaimer</a></li><li><a class="link" href="/permissions-policy.html">Permissions Policy</a></li><li><a class="link" href="/editorial-policy.html">Editorial Policy</a></li><li><a class="link" href="/terms-and-conditions-of-use.html">Terms Of Service</a></li><li><a class="link" href="/privacy-policy.html">Privacy Policy</a></li><li><a class="link" href="/email-whitelisting.html">Email Whitelisting</a></li><li><a class="link" href="/jobs.html">Employment Opportunities</a></li></ul></div><div><h3>Stay Connected</h3><ul><li><a class="link" href="/signup">Sign Up</a></li><li><a class="link" href="/voice/signup">Submit an Article</a></li><li><a class="link" href="/contact-us.html">Contact Us</a></li><li><a class="link" href="mailto:ChristianPost@pinkston.co" target="_self">Media Contact</a></li><li><a class="link" href="/advertising.html" target="_blank">Advertise With Us</a></li><li><a class="link" href="/rss-feed.html">RSS Feed</a></li><li><a class="link" href="/archives.html">Archives</a></li><li><a class="link" href="/corrections.html">Corrections</a></li><li><a class="link" href="/faq.html">Commenting FAQ</a></li><li><a class="link" href="/community-guidelines.html">Community Guidelines</a></li></ul></div><div><div class="has-bottom-gap"><h3>Follow Us</h3><ul><li><a class="facebook" href="https://www.facebook.com/ChristianPost.Intl" target="_blank"><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M94.626 144H73.012V90.057H55v-20.95h18.012V53.693c0-8.83 2.561-15.733 7.685-20.71C85.5 28.328 91.904 26 99.909 26c4.483 0 9.847.24 16.091.722v18.784h-11.287c-6.725 0-10.087 3.05-10.087 9.151v14.45h20.654l-2.642 20.95H94.626V144z" fill="currentColor"/></svg></span></span> Facebook</a></li><li><a class="twitter" href="https://twitter.com/ChristianPost" target="_blank"><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M146 47.753s-4.762 7.685-12.472 12.884C135.115 95.897 109.264 135 62.323 135 38.967 135 24 123.699 24 123.699s18.368 3.842 36.963-10.172c-18.822-1.13-23.357-17.404-23.357-17.404s5.216 1.356 11.338-.452c-21.089-5.198-20.182-24.863-20.182-24.863s5.216 3.165 11.338 3.165C21.052 59.28 32.39 40.52 32.39 40.52s17.235 24.185 51.703 26.22c-4.989-27.35 26.532-40.007 42.632-22.829 8.39-1.356 16.1-6.103 16.1-6.103s-2.72 9.267-11.111 13.788c6.803-.452 14.286-3.843 14.286-3.843z" fill="currentColor"/></svg></span></span> Twitter</a></li><li><a class="instagram" href="https://www.instagram.com/christianpostintl" target="_blank"><span class="i-social"><span class="i-container"><svg width="32" height="32" viewBox="0 0 800 800" xmlns="http://www.w3.org/2000/svg"><path fill="currentColor" d="M150 400c0-119 0-166 42-208s88-42 208-42 166 0 208 42 42 89 42 208 0 166-42 208-88 42-208 42-166 0-208-42-42-89-42-208zm455 0c0-114 0-148-29-176-29-29-62-29-176-29s-148 0-176 29c-29 29-29 62-29 176s0 148 29 176c29 29 62 29 176 29s148 0 176-29c29-29 29-62 29-176zM400 272a128 128 0 1 1 0 256 128 128 0 0 1 0-256zm0 211c46 0 83-37 83-83s-37-83-83-83-83 37-83 83 37 83 83 83zm163-216c0 16-13 30-30 30-16 0-30-14-30-30 0-17 14-30 30-30 17 0 30 13 30 30z"></path></svg></span></span>Instagram</a></li></ul></div><div><h3>Mobile Apps</h3><ul><li><a href="https://apps.apple.com/au/app/the-christian-post/id1584395665" target="_blank" rel="noreferrer">iOS app</a></li><li><a href="https://play.google.com/store/apps/details?id=com.christianpost.android&amp;hl=en_US&amp;gl=US" target="_blank" rel="noreferrer">Android app</a></li></ul></div></div></div></nav><div class="copyright"> &nbsp; <span itemprop="copyrightYear">2022</span><span itemprop="copyrightHolder provider sourceOrganization" itemscope itemtype="http://schema.org/Organization" itemid="https://www.christianpost.com"><span itemprop="name">The Christian Post, INC</span></span>. All Rights Reserved. </div></div></footer><div id="g_id_onload"></div> <script type="text/javascript" src="https://cdn.christianpost.com/assets/js/script.js"></script> <script type="text/javascript" src="https://cdn.christianpost.com/assets/js.js"></script> </body></html>