<!DOCTYPE html><html class="no-script" lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="https://www.facebook.com/2008/fbml" ><head itemscope itemtype="https://schema.org/WebSite"><title>Sean Feucht’s ‘Let Us Worship’ tour calls for revival in America | U.S. News | The Christian Post</title><meta name="keywords" content="Sean Feucht, Revival, Christianity, Religious Liberty, Addiction, Worship, Virginia Beach"><meta name="description" content="Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages."><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.christianpost.com/assets/img/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" href="https://cdn.christianpost.com/assets/img/favicons/favicon-32x32.png" sizes="32x32"><link rel="icon" type="image/png" href="https://cdn.christianpost.com/assets/img/favicons/favicon-16x16.png" sizes="16x16"><link rel="manifest" href="/assets/img/favicons/manifest.json"><link rel="mask-icon" href="https://cdn.christianpost.com/assets/img/favicons/safari-pinned-tab.svg" color="#2577cf"><link rel="shortcut icon" href="https://cdn.christianpost.com/assets/img/favicons/favicon.ico"><meta name="msapplication-config" content="/assets/img/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><meta name="HandheldFriendly" content="True"><meta name="MobileOptimized" content="320"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="black-translucent"><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta property="fb:pages" content="41093998634" /><meta property="og:ttl" content="2419200" /><meta charset="utf-8"><script type="text/javascript">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</script><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="facebook-domain-verification" content="j68jf4grzfp57oqi4w2kcizgc7d6m9" /><meta name="msvalidate.01" content="2770D3F1DEB25A5BF965224150B525F4" /><meta name="google-site-verification" content="jUJZk866mtO5Gxkt7Qz98Q6XIzxevyn3ngdiSJLpP34" /><meta property="og:site_name" content="The Christian Post" /> <script>-1!==location.search.indexOf("abspl=ZmJ2aXJhbA")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","ZmJ2aXJhbA","; path=/;"].join(""));-1!==location.search.indexOf("abspl=b3V0YnJhaW4")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","b3V0YnJhaW4","; path=/;"].join(""));!function(){var a=location.href;var p=function(){var i,t={},s=/=/.test(a),n=(s?a:location.search.substring(1)).split("&");-1!==location.search.indexOf("abspl=YmluZ2Fkcw")&&(document.cookie=["abok","=","1","; path=/;"].join(""),document.cookie=["abspl","=","YmluZ2Fkcw","; path=/;"].join(""));for(p in n)i=n[p].split("="),t[i[0]]=i[1];return!a||s?t:t[a]}();p&&p.absid&&(document.cookie=["absid","=",p.absid,"; path=/;"].join(""));p&&p.abcid&&(document.cookie=["abcid","=",p.abcid,"; path=/;"].join(""));}();</script><script>!function(){var a,b,c,d,e,f,g,h,i,j,k="cssc",l=new Date,m=new Date;return m.setDate(1),m.setMonth(m.getMonth()-1),a=k+l.getYear()+l.getMonth(),b=k+m.getYear()+m.getMonth(),c=function(a,b){var c=[a,"=",JSON.stringify(b),"; path=/;expires="+new Date(Date.now()+5184e6).toGMTString()].join("");document.cookie=c},d=function(a,b,c){var d=document.cookie.match(new RegExp(a+"=([^;]+)"));return d?(d=JSON.parse(d[1]),d||0):(d=document.cookie.match(new RegExp(b+"=([^;]+)")))?(d=JSON.parse(d[1]),Math.floor((d||0)/2)):(d=document.cookie.match(new RegExp(a+"=([^;]+)")),d&&(d=JSON.parse(d[1])),d||0)},e=function(a){var b;return b=a.indexOf("://")>-1?a.split("/")[2]:a.split("/")[0],b=b.split(":")[0]},f=d(a,b,k),g=function(){var a=0,b=36,c=(new Date).getHours(),d=(new Date).getDay();(c>19||c<7||Math.random()<.5&&12==c)&&(a=9999),0!=d&&6!=d||(a=9999),window.spSampleMarker=!(f>=a),Math.random()<.7&&f>=b&&(window.spSampleMarker=!0),window.spSampleMarkerScore=f},location.href===document.referrer?void g():(h=function(){return this._score},i=function(b){f+=b,f>=9999&&(f-=1e3),c(a,f)},j=0,"en-US"!==navigator.language&&(j-=1),document.referrer?"/"===location.pathname&&(document.referrer.includes("google")||document.referrer.includes("yahoo")||document.referrer.includes("bing")||document.referrer.includes("baidu"))?j+=5:location.hostname===e(document.referrer)||(j-=6):j+=7,i(j),void g())}();</script><script>window.cmc_ab_test = Math.floor(Math.random() * 4);</script><script>window.ab = document.referrer.indexOf('/tv/') !== -1 && document.referrer.indexOf(location.hostname) !== -1; window.abok = (document.cookie.indexOf('abok=1') !== -1); if(window.abok){window.ab=true;}; window.ab && (window.spSampleMarker=!0); var gc = function(n) { parts = ("; " + document.cookie).split("; "+n+"="); if (parts.length == 2) return parts.pop().split(";").shift(); }; window.abspl = gc('abspl'); window.absid = gc('absid'); window.abcid = gc('abcid'); window.arcnt = parseInt(gc('cmc_arcnt'))||0;</script> <script>
  dataLayer = [{"_":"_","page_type":"articles","category":["us"],"article_id":"243500","article_title":"Hundreds gather to proclaim name of Jesus at Sean Feucht \u2018Let Us Worship\u2019 summer tour","article_keywords":"Sean Feucht, Revival, Christianity, Religious Liberty, Addiction, Worship, Virginia Beach","article_type":"n","reporter":"anugrah-kumar","slideshow":false}];
  !function(t,e){t[e]=t[e]||[],t[e].push({"gtm.start":(new Date).getTime(),event:"gtm.js"})}(window,"dataLayer");
</script> <script async="async" src="https://www.googletagmanager.com/gtm.js?id=GTM-M3XGPPX"></script> <script>
    var base_url   = "/";
    var cp_domain  = "www.christianpost.com";
    var static_url = "https://cdn.christianpost.com/";
    const isCustomerSession = false;
    const role = "guest";
    const spotim_id = "sp_BCbDgHvV";
    var html = document.documentElement;
    html.className = html.className.replace('no-script', 'has-script');
</script> <script data-rh="true" type="application/ld+json">
    {
        "@context":"http://schema.org",
        "@type":"NewsMediaOrganization",
        "name":"The Christian Post",
        "alternateName": "CP",
        "logo":{
            "@context":"http://schema.org",
            "@type":"ImageObject",
            "url":"https://cdn.christianpost.com/assets/img/logo.png",
            "height":28,"width":559
        },
        "address": {
            "@type": "PostalAddress",
            "addressCountry": "US",
            "addressLocality": "Washington",
            "addressRegion": "District of Columbia",
            "postalCode": "20011"
        },
        "url":"https://www.christianpost.com/",
        "diversityPolicy":"https://www.christianpost.com/privacy-policy.html",
        "ethicsPolicy":"https://www.christianpost.com/editorial-policy.html",
        "masthead":"https://www.christianpost.com/leadership.html",
        "sameAs":[
            "https://www.facebook.com/ChristianPost.Intl",
            "https://twitter.com/ChristianPost",
            "https://www.instagram.com/christianpostintl",
            "https://www.youtube.com/user/TheChristianpost",
            "https://www.linkedin.com/company/the-christian-post",
            "https://www.wikidata.org/wiki/Q9684",
            "https://www.reddit.com/domain/christianpost.com",
            "https://en.wikipedia.org/wiki/The_Christian_Post"
        ]
    }
</script> <link rel="subresource" href="https://cdn.christianpost.com/assets/css/main.css"><link rel="stylesheet" href="https://cdn.christianpost.com/assets/css/main.css"> <script>
                            var tracking_pix = '/statistics/pixel/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpYXQiOjE2MjM2MjI0MzAsImV4cCI6MTYyMzYyMjQzMywiaWQiOiIyNDM1MDAiLCJyZXBvcnRlcl9pZCI6NjAyLCJhdXRob3JfaWQiOiI2MzIiLCJyZWZmZXIiOiIiLCJjYXRlb2dyeV9pZCI6IjExNiJ9.AnEGipsiMGNrrwWVMTOzboMRF5sRTh5ZmMcVcTyJ7To.gif'
            
                            var ias_urls  = ["/news/beach-revival-underway-in-so-calif-a-return-to-a-gritty-raw-gospel-jesus-people-movement.html","/sponsored/does-your-counselor-share-your-faith.html","/news/police-prevent-sean-feucht-and-team-from-setting-up-for-worship-night-in-chicago.html","/sponsored/are-you-prepared-to-engage-a-post-christian-culture.html"];
            
                            let isCommentDisabled = false;
                    </script> <link rel="amphtml" href="https://www.christianpost.com/amp/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html"><meta property="og:url" content="https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" /><meta property="og:type" content="website" /><meta property="og:title" content="Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" /><meta property="og:description" content="Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages." /><meta property="og:image" content="https://cdn.christianpost.com/files/original/thumbnail/24/35/243500.jpg" /><meta property="fb:pages" content="41093998634"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@ChristianPost"><meta name="twitter:creator" content="@ChristianPost"><meta name="twitter:title" content="Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour"><meta name="twitter:description" content="Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages."><meta name="twitter:image" content="https://cdn.christianpost.com/files/original/thumbnail/24/35/243500.jpg"><link rel="canonical" href="https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html"> <script type="application/ld+json">
    {
      "@context": "https://schema.org",
      "@type": "NewsArticle",
      "mainEntityOfPage": "https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html",
      "url": "https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html",
              "keywords":["Sean Feucht"," Revival"," Christianity"," Religious Liberty"," Addiction"," Worship"," Virginia Beach"],
            "headline": "Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour",
      "datePublished": "2021-06-13T16:12:02-04:00",
      "dateModified":  "2021-06-13T16:41:43-04:00",
      "description":   "Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages.",
                 "author": {
                "@context":"http://schema.org",
                "@type": "Person",
                "url":"https://www.christianpost.com/by/anugrah-kumar",
                "name": "Anugrah Kumar"
           },
           "creator":"Anugrah Kumar",
                          "articleSection":"U.S.",
               "inLanguage": "en"
    }
  </script> <script type="application/ld+json">
        [{
              "@context": "https://schema.org",
              "@type": "BreadcrumbList",
               "name": "Latest Christian News of U.S.",
              "itemListElement": [{
                      "@type": "ListItem",
                      "position": 1,
                      "name": "Christian Post",
                      "item": "https://www.christianpost.com"
                  },{
                      "@type": "ListItem",
                      "position": 2,
                      "name": "U.S.",
                      "item": "https://www.christianpost.com/cateogry/us"
                  },{
                      "@type": "ListItem",
                      "position": 3,
                      "name": "Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour"
              }]
             }
            ,
            {
              "@context": "https://schema.org",
              "@type": "BreadcrumbList",
              "name": "Latest Christian News",
              "itemListElement": [{
                  "@type": "ListItem",
                  "position": 1,
                  "name": "Christian Post",
                  "item": "https://www.christianpost.com"
              },{
                "@type": "ListItem",
                "position": 2,
                "name": "News",
                "item": "https://www.christianpost.com/news"
              },{
                "@type": "ListItem",
                "position": 3,
                "name": "Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour"
              }]
            }
        ]
        </script> </head><body class="normal-version article-page"><header class="site-header-container " role="banner"><div class="site-header fixed-header" aria-hidden="true"><div class="container"><div class="headbar"><div class="tools" aria-hidden="true"><a class="logo-abbr" href="/"><img src="/assets/img/cp.svg" alt="The Christian Post" width="52" height="22"></a><button class="nav-toggle mobile-only" data-js-toggle=".offcanvas"><span class="i-nav"><span></span></span></button><button class="nav-toggle desktop-only" data-js-toggle="#main-nav"><span class="i-nav"><span></span></span></button><button class="search-toggle" data-js-toggle="#main-search"><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span><span class="visually-hidden">Search</span></button></div><div class="headbar-main" aria-hidden="true"><div class="header-page-title">Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour</div></div><div class="desktop-only" style="float:right;"><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html">Subscribe</a></div></div></div></div></div><p class="visually-hidden">The Christian Post</p><a href="#main" class="skip-link visually-hidden">Skip to main content</a><noscript><p class="enable-js"> To enjoy our website, you'll need to enable <b>JavaScript</b> in your web browser. Please <a href="http://enable-javascript.com/" target="_blank"><b>click here</b></a> to learn how. </p></noscript><!--[if lt IE 9]><p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/" target="_blank">upgrade your browser</a> to improve your experience.</p><![endif]--><div class="offcanvas" id="offcanvas"><div class="container"><button class="btn-close mobile-only" data-js-toggle="#offcanvas" aria-hidden="true"><span class="i-close"><span></span></span></button></div><div class="container"><nav class="main-nav" id="main-nav" role="navigation" aria-label="Main Navigation"><button class="btn-close desktop-only" data-js-toggle="#main-nav" aria-hidden="true"><span class="i-close"><span></span></span></button><ul id="cp_header_menu"><li class=" "><a href="/" class="link">Home</a></li><li class=" "><a href="/news" class="link">Latest News</a></li><li class=" "><a href="/category/church-ministries" class="link">Church &amp; Ministries</a></li><li class=" "><a href="/category/us" class="link">U.S.</a></li><li class=" "><a href="/category/world" class="link">World</a></li><li class=" "><a href="/category/politics" class="link">Politics</a></li><li class=" "><a href="/category/entertainment" class="link">Entertainment</a></li><li class=" "><a href="/category/living" class="link">Living</a></li><li class=" "><a href="/opinion" class="link">Opinion</a></li><li class=" "><a href="/business" class="link">Business</a></li><li class=" "><a href="/sports" class="link">Sports</a></li><li class=" "><a href="/education" class="link">Education</a></li><li class=" "><a href="/lifestyle" class="link">Lifestyle</a></li><li class=" "><a href="/shopping" class="link">Shopping</a></li><li class=" "><a href="/books" class="link">Books</a></li><li class=" "><a href="/church-resource" class="link">Church Resource</a></li><li class=" "><a href="https://video.christianpost.com/" class="link">Video</a></li><li class=" "><a href="/podcast" class="link">Christian Podcasts</a></li><li class="link-topics" id="topics"><a href="/topic" class="link">Christian Topics</a></li><li class="has-subnav "><a class="link">Brand Voice</a><div class="subnav-panel"><ul><li><a href="https://www.christianpost.com/offers/christian-education/liberty-university">Liberty University</a></li></ul></div></li><li class="cp-menu last"><a href="/jobs.html" class="link">Job Board</a></li></ul></nav><div class="edition"><span><strong>Edition</strong></span><span class="current"><span class="visually-hidden">Current Edition: </span>English</span><a class="link" href="https://spanish.christianpost.com/" target="_blank">Español</a><a class="link" href="https://chinese.christianpost.com/" target="_blank">中文</a><a class="switch-link" href="/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html?mobile=true">Switch to Modern Version</a></div></div></div><form class="main-search search-form" id="main-search" action="/search" method="get" aria-label="Main Search Field" ><div class="container" role="search"><div class="search-container"><div class="visually-hidden" role="alert" aria-relevant="all"></div><input id="main-search-input" type="search" name="s" placeholder="Search" aria-label="Search"><button class="btn-submit"><span class="visually-hidden">Go</span><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span></button></div><button class="btn-close" data-js-toggle="#main-search" aria-hidden="true"><span class="i-close"><span></span></span></button></div></form><div class="site-header"><div class="container"><div class="headbar"><div class="tools" aria-hidden="true"><button class="nav-toggle mobile-only" data-js-toggle=".offcanvas"><span class="i-nav"><span></span></span></button><button class="nav-toggle desktop-only" data-js-toggle="#main-nav"><span class="i-nav"><span></span></span></button><button class="search-toggle" data-js-toggle="#main-search"><span class="i-search"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><g stroke="currentColor" stroke-width="2" fill="none" fill-rule="evenodd"><path d="M28.18 28.18l11.76 11.76"/><circle cx="18.5" cy="18.5" r="14"/></g></svg></span></span><span class="visually-hidden">Search</span></button></div><div class="headbar-main" aria-hidden="true"><div class="branding" id="branding"><a href="/"><img src="/assets/img/logo.svg" alt="Go to Homepage" width="595" height="31"></a></div></div><div class="desktop-only" style="float:right;"><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html">Subscribe</a></div></div></div></div><div class="dateline-mb mobile-only"><div class="container"><time style="float: left; padding-top: 10px; " class="today" datetime="Sunday, Jun 13, 2021">Sunday, Jun 13, 2021</time><div class="loginline login-line" id="login-line" style="float: right;"><a class="link-login" target="_top" href="/login?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" >Log In</a><a class="link-subscribe loud" target="_top" href="/signup?redirect_url=/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html">Subscribe</a></div></div></div></div></header> <script type="text/javascript" src="https://cdn.christianpost.com/vendor/js/jquery-1.11.0.min.js"></script> <script type="text/javascript" src="https://cdn.christianpost.com/vendor/jquery-cookie/jquery.cookie.js"></script> <main id="main" role="main" tabindex="-1" style="overflow-x: hidden;" ><section class="topbar-news-wrapper" data-click-type="topbar-news"><h2 class="visually-hidden">Recommended</h2><div class="inner"><ul class="img-on-left topbar-news slider-fallback"><li><a href="/news/city-pays-35k-to-christian-ministry-for-canceling-event-over-speakers-biblically-based-views.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243497_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/city-pays-35k-to-christian-ministry-for-canceling-event-over-speakers-biblically-based-views.html">City pays over $35K to Christian ministry for canceling event over speaker’s biblically-based views</a></h3></li><li><a href="/news/this-week-in-christian-history-salvation-army-founders-wed.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243479_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/this-week-in-christian-history-salvation-army-founders-wed.html">This week in Christian history: Episcopal Church elects first female leader, Salvation Army founders wed</a></h3></li><li><a href="/news/texas-gov-greg-abbott-to-release-plans-for-building-border-wall.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243489_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/texas-gov-greg-abbott-to-release-plans-for-building-border-wall.html">Texas Gov. Greg Abbott to release plans for building border wall as migrant numbers rise over 180,000</a></h3></li><li><a href="/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/35/243500_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html">Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour</a></h3></li><li><a href="/voices/we-build-playgrounds-in-war-zones.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243485_a_66_66_657_697.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/we-build-playgrounds-in-war-zones.html">We build playgrounds in war zones</a></h3></li><li><a href="/voices/what-it-looks-like-to-be-exceptionally-employable.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243453_a_66_66_153_113.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/what-it-looks-like-to-be-exceptionally-employable.html">What it looks like to be exceptionally employable </a></h3></li><li><a href="/voices/politics-makes-a-lousy-worldview.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243473_a_66_66.jpg" width="66" height="66"/></a><h3 class="h5"><a class="link" href="/voices/politics-makes-a-lousy-worldview.html">Politics makes a lousy worldview</a></h3></li></ul></div></section><div class="article-cell" data-data-layer="{&quot;_&quot;:&quot;_&quot;,&quot;page_type&quot;:&quot;articles&quot;,&quot;category&quot;:[&quot;us&quot;],&quot;article_id&quot;:&quot;243500&quot;,&quot;article_title&quot;:&quot;Hundreds gather to proclaim name of Jesus at Sean Feucht \u2018Let Us Worship\u2019 summer tour&quot;,&quot;article_type&quot;:&quot;n&quot;,&quot;reporter&quot;:&quot;anugrah-kumar&quot;,&quot;r_id&quot;:&quot;602&quot;,&quot;slideshow&quot;:false,&quot;a_id&quot;:&quot;632&quot;}"><div class="container"><div class="sec-line breadcrumbs"><a aria-hidden="true" href="/">CP</a><span class="visually-hidden">Current Page: </span><a href="/category/us"><span class="sec-name" >&nbsp;U.S.</span> | <time datetime="Sunday, June 13, 2021" itemprop="datePublished dateModified">Sunday, June 13, 2021</time> | </a><a class="tag" href="/topic/coronavirus.html">Coronavirus →</a></div><div class="main-layout sticky-layout"><div><article class="full-article" id="article_content"><header><h1 class="article-title">Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour</h1><div class="article-byline">By <span itemprop="author creator" itemtype="http://schema.org/Person" itemid="/by/anugrah-kumar"><a class="reporter" href="/by/anugrah-kumar"><span itemprop="name">Anugrah Kumar</span></a></span>, Christian Post Contributor <time class="visually-hidden"> | Sunday, June 13, 2021</time></div></header><div class="share-icons"><a class="social-share-button i-circle facebook" href="http://www.facebook.com/sharer.php?u=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" target="_blank" data-click-type="share-facebook"><span class="txt visually-hidden">Facebook</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M94.626 144H73.012V90.057H55v-20.95h18.012V53.693c0-8.83 2.561-15.733 7.685-20.71C85.5 28.328 91.904 26 99.909 26c4.483 0 9.847.24 16.091.722v18.784h-11.287c-6.725 0-10.087 3.05-10.087 9.151v14.45h20.654l-2.642 20.95H94.626V144z" fill="currentColor"/></svg></span></span></a><a class="social-share-button i-circle twitter" href="https://twitter.com/intent/tweet?url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&text=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" target="_blank" data-click-type="share-twitter"><span class="txt visually-hidden">Twitter</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M146 47.753s-4.762 7.685-12.472 12.884C135.115 95.897 109.264 135 62.323 135 38.967 135 24 123.699 24 123.699s18.368 3.842 36.963-10.172c-18.822-1.13-23.357-17.404-23.357-17.404s5.216 1.356 11.338-.452c-21.089-5.198-20.182-24.863-20.182-24.863s5.216 3.165 11.338 3.165C21.052 59.28 32.39 40.52 32.39 40.52s17.235 24.185 51.703 26.22c-4.989-27.35 26.532-40.007 42.632-22.829 8.39-1.356 16.1-6.103 16.1-6.103s-2.72 9.267-11.111 13.788c6.803-.452 14.286-3.843 14.286-3.843z" fill="currentColor"/></svg></span></span></a><a class="social-share-button i-circle email" href="mailto:?subject=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour&amp;body=Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages.page:https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" data-click-type="share-email"><span class="txt visually-hidden">Email</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M134.454 37C140.77 37 146 42.236 146 48.564v72.872c0 6.328-5.229 11.564-11.546 11.564H35.546C29.23 133 24 127.764 24 121.436V48.564C24 42.236 29.229 37 35.546 37h98.908zm-1.525 24.655V50.09L85 82.164 37.071 50.09v11.564L85 93.727l47.929-32.072z" fill="currentColor"/></svg></span></span></a><button title="Print Option" class="i-circle print" data-js-toggle=".hidden-print-icons"><span class="txt visually-hidden">Print</span><span class="i-social"><span class="i-container"><svg width="800" height="800" viewBox="0 0 800 800" xmlns="http://www.w3.org/2000/svg"><path d="M676 229.46h-69.918V167c0-16.569-13.432-30-30-30H223.917c-16.568 0-30 13.431-30 30v62.46H124c-16.569 0-30 13.43-30 30v201.856c0 16.568 13.431 30 30 30h69.92V633c0 16.569 13.43 30 30 30h352.16c16.57 0 30-13.431 30-30V491.317H676c16.569 0 30-13.432 30-30V259.459c0-16.568-13.431-30-30-30zm-29.55 84.083c-12.071 0-21.857-9.79-21.857-21.865s9.786-21.865 21.857-21.865c12.07 0 21.857 9.79 21.857 21.865 0 12.076-9.786 21.865-21.857 21.865zM546.103 625.008H253.898c-8.284 0-15-6.716-15-15V399.584h322.205v210.424c0 8.284-6.716 15-15 15zm15-395.549H238.899v-39.468c0-8.284 6.716-15 15-15h292.206c8.284 0 15 6.716 15 15v39.468z" fill="currentColor"/></svg></span></span></button><span class="hidden-print-icons"><button class="i-circle img js-print-img" title="Print With Image"><span class="txt visually-hidden">Img</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M118.879 51.98l34.345 75.56H18.06l39.548-48.952 28.209 21.482 33.063-48.09zm-1.524 17.293L87.775 112.3l-28.74-21.887-23.094 28.585h104.017l-22.603-49.725zM56.898 35c10.222 0 18.508 8.286 18.508 18.508S67.12 72.016 56.898 72.016 38.39 63.73 38.39 53.508 46.676 35 56.898 35zm0 8.542c-5.504 0-9.966 4.462-9.966 9.966s4.462 9.966 9.966 9.966 9.966-4.462 9.966-9.966-4.462-9.966-9.966-9.966z" fill="#121D2E"/></svg></span></span></button><button class="i-circle no-img js-print-no-img" title="Print Without Image"><span class="txt visually-hidden">No-img</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><g fill="none"><path d="M118.879 51.98l34.345 75.56H18.06l39.548-48.952 28.209 21.482 33.063-48.09zm-1.524 17.293L87.775 112.3l-28.74-21.887-23.094 28.585h104.017l-22.603-49.725zM56.898 35c10.222 0 18.508 8.286 18.508 18.508S67.12 72.016 56.898 72.016 38.39 63.73 38.39 53.508 46.676 35 56.898 35zm0 8.542c-5.504 0-9.966 4.462-9.966 9.966s4.462 9.966 9.966 9.966 9.966-4.462 9.966-9.966-4.462-9.966-9.966-9.966z" fill="#787878"/><path fill="#494949" d="M171.302 7.877l5.801 5.997L4.496 180.868l-5.801-5.997z"/></g></svg></span></span></button></span><button class="i-circle menu" data-js-toggle=".hidden-icons"><span class="txt visually-hidden">Menu</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M38.447 100a14.438 14.438 0 0 1-12.511-7.25 14.546 14.546 0 0 1 0-14.5A14.438 14.438 0 0 1 38.447 71c7.98 0 14.448 6.492 14.448 14.5S46.426 100 38.447 100zM85 100a14.438 14.438 0 0 1-12.512-7.25 14.546 14.546 0 0 1 0-14.5A14.438 14.438 0 0 1 85 71c7.98 0 14.447 6.492 14.447 14.5S92.98 100 85 100zm46.553 0a14.438 14.438 0 0 1-12.512-7.25 14.546 14.546 0 0 1 0-14.5A14.438 14.438 0 0 1 131.553 71C139.532 71 146 77.492 146 85.5s-6.468 14.5-14.447 14.5z" fill="currentColor" fill-rule="evenodd"/></svg></span></span></button><span class="hidden-icons"><a class="i-circle whatsapp" href="whatsapp://send?text=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html" data-click-type="share-whatsapp"><span class="txt visually-hidden">Whatsapp</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M115.246 98.415c1.017.506 1.779 2.531-.254 7.846-1.525 4.05-8.388 7.34-12.455 7.34-24.4 0-48.037-28.601-48.037-42.269 0-6.581 2.288-9.871 4.575-12.15 2.033-2.277 3.558-2.53 4.575-2.53h3.05c1.017 0 2.287 0 3.304 2.53l4.83 11.138c1.27 2.784-2.288 6.327-3.813 7.846-.763.76-1.525 1.772-.508 3.29 6.354 9.872 10.42 12.91 20.587 17.971 1.525.76 2.542.253 3.304-.506l4.83-6.075c1.27-1.518 2.287-1.012 3.303-.506l12.709 6.075zm-29.992-64.29c-27.958 0-50.579 22.78-50.579 50.369 0 17.211 8.896 28.601 8.896 28.601l-5.084 18.73 19.317-5.062s10.675 8.1 27.45 8.1c27.959 0 50.58-22.527 50.58-50.37 0-28.095-22.621-50.369-50.58-50.369zm0-10.125C119.058 24 146 51.336 146 84.494c0 33.41-27.45 60.494-60.746 60.494-17.029 0-28.975-7.34-28.975-7.34L24 146l8.642-31.386s-8.134-12.402-8.134-30.12C24.508 51.336 51.958 24 85.254 24z" fill="currentColor"/></svg></span></span></a><a class="i-circle google" href="https://plus.google.com/share?url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&amp;text=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" data-click-type="share-google"><span class="txt visually-hidden">Google</span><span class="i-social"><span class="i-container"><svg viewBox="0 0 800 800" xmlns="http://www.w3.org/2000/svg"><path fill="currentColor" d="M651 363c23 168-80 297-246 297-144 0-260-116-260-260s116-260 260-260c70 0 130 26 175 68l-71 68c-19-19-53-40-104-40-89 0-161 73-161 164s72 164 161 164c104 0 142-74 148-112H405v-89h246z"/></svg></span></span></a><a class="i-circle reddit" href="http://reddit.com/submit?url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&amp;title=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" data-click-type="share-reddit"><span class="txt visually-hidden">Reddit</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd"><ellipse stroke="currentColor" fill="#FFF" fill-rule="nonzero" cx="133.981" cy="83.751" rx="12.019" ry="12.04"/><ellipse stroke="currentColor" fill="#FFF" fill-rule="nonzero" cx="36.019" cy="83.751" rx="12.019" ry="12.04"/><ellipse stroke="currentColor" cx="85" cy="100.334" rx="54.924" ry="36.166"/><path d="M85 136c-30.057 0-54.424-15.968-54.424-35.666 0-19.698 24.367-35.666 54.424-35.666s54.424 15.968 54.424 35.666C139.424 120.032 115.057 136 85 136zm-19.275-33.621c4.884 0 8.844-3.967 8.844-8.86 0-4.893-3.96-8.86-8.844-8.86-4.884 0-8.844 3.967-8.844 8.86 0 4.893 3.96 8.86 8.844 8.86zm38.55 0c4.884 0 8.844-3.967 8.844-8.86 0-4.893-3.96-8.86-8.844-8.86-4.884 0-8.844 3.967-8.844 8.86 0 4.893 3.96 8.86 8.844 8.86z" fill="#FFF" fill-rule="nonzero"/><path d="M118.561 41.724l-24.264-5.68-9.07 28.624m18.595 52.022S99.74 122.37 85 122.37c-14.74 0-18.822-5.68-18.822-5.68" stroke="currentColor"/><ellipse stroke="currentColor" fill="#FFF" fill-rule="nonzero" cx="128.086" cy="43.541" rx="9.524" ry="9.541"/></g></svg></span></span></a><a class="i-circle digg" href="http://digg.com/submit?url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&amp;title=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" data-click-type="share-digg"><span class="txt visually-hidden">Digg</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M43.52 49v17.033H24V107.4h31.72V49h-12.2zm0 48.667H36.2v-21.9h7.32v21.9zM60.6 66.033h12.2V107.4H60.6zM60.6 49h12.2v12.167H60.6zm17.08 17.033V107.4H97.2v4.867H77.68V122h31.72V66.033H77.68zM97.2 97.667h-7.32v-21.9h7.32v21.9zm17.08-31.634V107.4h19.52v4.867h-19.52V122H146V66.033h-31.72zm19.52 31.634h-7.32v-21.9h7.32v21.9z" fill="currentColor"/></svg></span></span></a><a class="i-circle stumbleupon" href="http://www.stumbleupon.com/submit?url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&amp;title=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour" data-click-type="share-stumbleupon"><span class="txt visually-hidden">Stumbleupon</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M85 38c-15.061 0-27.27 12.208-27.27 27.267v38.748a6.458 6.458 0 0 1-6.46 6.458 6.458 6.458 0 0 1-6.458-6.458V86.794H24v17.939C24 119.793 36.21 132 51.27 132c15.062 0 27.271-12.208 27.271-27.267V65.267A6.458 6.458 0 0 1 85 58.81a6.458 6.458 0 0 1 6.459 6.458v7.893l8.612 3.947 12.2-3.947v-7.893C112.27 50.207 100.06 38 85 38zm6.459 49.153v17.58c0 15.06 12.21 27.267 27.27 27.267C133.791 132 146 119.792 146 104.733V87.51h-20.812v17.222a6.458 6.458 0 0 1-6.459 6.458 6.458 6.458 0 0 1-6.458-6.458v-17.58l-12.2 3.946-8.612-3.946z" fill="currentColor"/></svg></span></span></a><a class="i-circle linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.christianpost.com/news/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html&amp;title=Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour&amp;summary=Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages.&amp;source=The%20Christian%20Post" data-click-type="share-linkedin"><span class="txt visually-hidden">Linkedin</span><span class="i-social"><span class="i-container"><svg viewBox="0 0 800 800" xmlns="http://www.w3.org/2000/svg"><path fill="currentColor" d="M268 629h-97V319h97zm157 0h-97V319h93v42h1q31-50 93-50 114 0 114 133v185h-96V466q0-70-49-70-59 0-59 69z"/><circle fill="currentColor" cx="219" cy="220" r="56"/></svg></span></span></a></span><span class="icon-divider"></span><a href="#cp-talk" class="i-circle cment talk-cp-243500" ><span class="txt visually-hidden">Comment</span><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M86.83 120.926a43.285 43.285 0 0 1-38.141 15.84 45.995 45.995 0 0 0 16.31-18.222C41.111 112.62 24 96.458 24 77.463 24 53.446 51.29 34 85 34s61 19.446 61 43.463c0 23.567-26.326 42.755-59.17 43.463z" fill="currentColor" fill-rule="evenodd"/></svg></span></span><span class="vf-comments-count comment-count spot-im-replies-count" data-post-id="christianpost.com-publication-243500" real-time="true">0</span></a></div><figure class="img-box align-center center" itemscope itemtype="https://schema.org/ImageObject"><picture width="760" height="431"><source type="image/webp" srcset="https://cdn.christianpost.com/files/cache/image/14/26/142615_w_760_431.webp"><img src="https://cdn.christianpost.com/files/cache/image/14/26/142615_w_760_431.png" alt="Let Us Worship" width="760" height="431"></source></picture><figcaption class="caption"><span itemprop="description" class="photo-des">"Let Us Worship" at Rock Church in Virginia Beach, Virginia. </span> | <span itemprop="author" class="credit">Screenshot: Instagram/Sean Feucht</span></figcaption></figure><p>Taking his “Let Us Worship” summer tour to his hometown of Virginia Beach, worship leader and songwriter Sean Feucht addressed hundreds gathered to proclaim the name of Jesus, stressing that America needs “revival in this hour like never before.” He also criticized Facebook for continuing to block and suppress his pages.</p><p>“Let Us Worship,” a mobile church movement that seeks to bring hope and joy to the divided nation and uphold the constitutional freedom of religion, was held at Rock Church in Virginia Beach on Friday night.</p><p>The hundreds of participants from diverse backgrounds sang and danced, lifting their hands in prayer, CBN News <a href="https://www1.cbn.com/cbnnews/us/2021/june/we-need-revival-like-never-before-sean-feucht-brings-let-us-worship-to-his-vb-hometown" target="_blank">reported</a>, adding that the praise and worship singer encouraged those suffering from addiction, anxiety and depression to be set free and receive God’s love.</p><p>“Witnessing this in my high school hometown was SO WILD! One of the most hungry & passionate #LetUsWorship revivalists we’ve worshipped with!!” the singer <a href="https://www.instagram.com/p/CQBrwr5AEoN/" target="_blank">wrote</a> on Instagram.</p><p>“America is at a tipping point and we need revival in this hour like never before,” Feucht told the Christian news site.</p><p>The mission of the tour, he said, was to “stand up for our First Amendment rights, religious liberties and the fact that people are hurting, suicide rates are exploding, drug and alcohol abuse.”</p><p>“But we felt like the Lord really shifted us hard into revival,” he added. “This is the season. We’ve stood our ground. We made a statement, we’re not going to back down but we’ve got to offer more. We can’t just be a political solution — it’s got to be a Heaven solution.”</p><p>The “Let Us Worship” tour, which began last summer, will carry on as long as Christians in cities continue to respond, he said.</p><p>Last July, Feucht told The Christian Post that he believes the church is in a season that resembles the late ‘60s and ‘70s, a period in U.S. history marked by political strife, racial tension, government instability and economic volatility.</p><p>“What we’re seeing now is a return back to a gritty, raw Gospel, Jesus people movement foundation. A lot of that is in part because we can’t be in our churches. We are kind of forced to be outside of our buildings and forced to be innovative and creative and come up with alternate solutions.”</p><p>He added, “And I think what it’s doing is stripping off the sheen and the polished nature of what we’ve built in America and it’s allowing us to return to the simplicity to the power of the raw Gospel.”</p><p>On Friday, the singer criticized Facebook for blocking his pages and designating them as “Dangerous content” for the last five months. He has been using the hashtag #BreakTheAlgorithm to help his followers get past Big Tech’s AI by sharing and commenting on their social media accounts.</p><p>“Crazy news today, but not surprising,” he wrote on <a href="https://www.instagram.com/seanfeucht/?utm_source=ig_embed&ig_rid=736380a6-2091-4ae3-870c-c3d6b25cb829" target="_blank">Instagram</a>. “Not sure how people are even hearing about the events to come! But Even BIG TECH CAN'T STOP the move of God!”</p></article><section class="inline-newsletter-oct20 design2 inline-newsletter-campaign" id="eoa_2"><div class="txt-wp"><h2 class="title">Free CP Newsletters</h2><p class="txt">Join over 250,000 others to get the top stories curated daily, plus special offers!</p></div><form method="post" class="newsletter-campaign-form" action="/newsletter/eoa-2.html"><div class="form-newsletter"><input class="input-basic" name="email" type="email" placeholder="Enter your email" required="required"><button class="submit-newsletter-form button-basic submit-eoa-2">Submit</button></div><div role="alert" aria-relevant="all" class="newsletter-message-body"></div></form></section><section class="related-stories col bold" data-click-type="related-articles"><h2 class="col-header">Related Articles</h2><div class="inner"><ul class="related-story-list img-on-left slider-fallback no-bullet"><li><a href="/news/beach-revival-underway-in-so-calif-a-return-to-a-gritty-raw-gospel-jesus-people-movement.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/23/79/237916_a_85_85.jpg" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/beach-revival-underway-in-so-calif-a-return-to-a-gritty-raw-gospel-jesus-people-movement.html">Beach revival underway in So. Calif: 'A return to a gritty, raw Gospel, Jesus people movement'</a></h3></li><li><a href="/news/police-prevent-sean-feucht-and-team-from-setting-up-for-worship-night-in-chicago.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/23/90/239033_a_85_85.jpg" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/police-prevent-sean-feucht-and-team-from-setting-up-for-worship-night-in-chicago.html">Police prevent Sean Feucht and team from setting up for worship night in Chicago </a></h3></li><li><a href="/news/missionary-sean-feucht-faces-opposition-over-la-new-years-events.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/07/240798_a_85_85.jpg" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/missionary-sean-feucht-faces-opposition-over-la-new-years-events.html">Missionary Sean Feucht faces opposition over LA New Year’s events</a></h3></li><li><a href="/news/jon-voight-tells-sean-feucht-americas-freedom-is-under-attack.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/11/241165_a_85_85.png" width="85" height="85"/></a><h3 class="h4"><a class="link" href="/news/jon-voight-tells-sean-feucht-americas-freedom-is-under-attack.html">Jon Voight tells Sean Feucht: America’s freedom is ‘under attack by an atheist force’</a></h3></li></ul></div></section><section class="col bold" data-click-type="sponsored-article-bottom"><h2 class="col-header quiet">Sponsored</h2><ul class="has-divider img-on-left list-col2 at-top"><li><a href="/sponsored/are-you-prepared-to-engage-a-post-christian-culture.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/03/393_a_120_80.jpg?0029191001623351212" alt="Are You Prepared to Engage a Post-Christian Culture?" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/are-you-prepared-to-engage-a-post-christian-culture.html" rel="sponsored">Are You Prepared to Engage a Post-Christian Culture?</a></h3></div></li><li><a href="/sponsored/does-your-counselor-share-your-faith.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/03/392_a_120_80.jpg?0030082001623351212" alt="Does your counselor share your faith?" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/does-your-counselor-share-your-faith.html" rel="sponsored">Does your counselor share your faith?</a></h3></div></li><li><a href="/sponsored/build-a-better-you-build-a-better-business.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/03/391_a_120_80.jpg?0032044001623351212" alt="Build a Better You . . . Build a Better Business" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/build-a-better-you-build-a-better-business.html" rel="sponsored">Build a Better You . . . Build a Better Business</a></h3></div></li><li><a href="/sponsored/as-persecution-intensifies-we-must-pray-for-boldness-rather-than-safety.html" rel="sponsored"><img src="https://cmcioffer-thechristianpost.netdna-ssl.com/files/cache/thumbnail/0/03/390_a_120_80.jpg?0032692001623351212" alt="As Persecution Intensifies, &ldquo;We Must Pray for Boldness Rather than Safety&rdquo;" width="120" height="80" /></a><div><h3 class="h4"><a class="link" href="/sponsored/as-persecution-intensifies-we-must-pray-for-boldness-rather-than-safety.html" rel="sponsored">As Persecution Intensifies, &ldquo;We Must Pray for Boldness Rather than Safety&rdquo;</a></h3></div></li></ul></section><div data-spotim-module="pitc"></div><div id="cp-talk" data-spotim-module="conversation" data-post-id="christianpost.com-publication-243500"></div></div><div><section><section class="col bold" data-click-type="most-popular"><h2 class="col-header">Most Popular</h2><article><a href="/news/steve-austin-former-pastor-who-shared-mental-heath-struggles-dead-at-38.html"><img src="https://cdn.christianpost.com/files/cache/image/13/68/136845_a_963_642_7_7.jpg" srcset="https://cdn.christianpost.com/files/cache/image/13/68/136845_a_300_200_7_7.jpg 300w,https://cdn.christianpost.com/files/cache/image/13/68/136845_a_600_400_7_7.jpg 600w,https://cdn.christianpost.com/files/cache/image/13/68/136845_a_963_642_7_7.jpg 963w" sizes="(max-width: 1023px) 100vw, 300px" width="963" height="642"/></a><h3 class="h2"><a class="link" href="/news/steve-austin-former-pastor-who-shared-mental-heath-struggles-dead-at-38.html">Steve Austin, former Alabama pastor who shared mental health struggles, found dead</a></h3></article><ul class="has-divider img-on-left at-top"><li><a href="/news/terry-crews-wife-rebecca-shares-how-god-restored-marriage-after-porn-addiction-infidelity.html"><img src="https://cdn.christianpost.com/files/cache/image/14/26/142607_a_130_72_580_254.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/terry-crews-wife-rebecca-shares-how-god-restored-marriage-after-porn-addiction-infidelity.html">Terry Crews' wife Rebecca shares how God restored marriage after porn addiction, infidelity</a></h3></div></li><li><a href="/news/city-pays-35k-to-christian-ministry-for-canceling-event-over-speakers-biblically-based-views.html"><img src="https://cdn.christianpost.com/files/cache/image/14/26/142614_a_130_72_7_7.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/city-pays-35k-to-christian-ministry-for-canceling-event-over-speakers-biblically-based-views.html">City pays over $35K to Christian ministry for canceling event over speaker’s biblically-based views</a></h3></div></li><li><a href="/news/netflix-temporarily-halts-filming-gods-favorite-idiot.html"><img src="https://cdn.christianpost.com/files/cache/image/12/08/120803_a_130_72_7_7.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/netflix-temporarily-halts-filming-gods-favorite-idiot.html">Netflix temporarily halts 'God's Favorite Idiot' after filming only 8 episodes</a></h3></div></li><li><a href="/news/wisconsin-cant-force-religious-schools-to-shut-down-court-rules.html"><img src="https://cdn.christianpost.com/files/cache/image/14/22/142293_a_130_72_593_223.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/news/wisconsin-cant-force-religious-schools-to-shut-down-court-rules.html">‘Major victory’: Wisconsin can’t force private, religious schools to shut down</a></h3></div></li></ul></section><section class="rightrail-newsletter-oct20 design2" id="rr-2"><div class="heading">The Christian Post Newsletter</div><h2 class="title">Get on the List</h2><p class="txt1"><span>Do you want award-winning journalism with a <span class="nw">Christian worldview</span>, delivered to your inbox?</span></p><form class="newsletter-campaign-form" action="/newsletter/sidebar-bottom.html" method="post"><input class="input-basic" name="email" type="email" placeholder="Enter your email" required="required"><button class="submit-newsletter-form button-basic submit-sidebar-bottom">Submit</button><div role="alert" aria-relevant="all" class="newsletter-message-body"></div></form><p class="txt2">Join over 250,000 others to get the top stories curated daily, plus special offers!</p></section></section><section class="col bold" data-click-type="more-in-section"><h2 class="col-header">More In U.S.</h2><ul class="has-divider img-on-left in-middle"><li><a href="/us/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/35/243500_a_130_72.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/us/sean-feuchts-let-us-worship-tour-calls-for-revival-in-america.html">Hundreds gather to proclaim name of Jesus at Sean Feucht ‘Let Us Worship’ summer tour</a></h3></div></li><li><a href="/us/steve-austin-former-pastor-who-shared-mental-heath-struggles-dead-at-38.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243496_a_130_72.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/us/steve-austin-former-pastor-who-shared-mental-heath-struggles-dead-at-38.html">Steve Austin, former Alabama pastor who shared mental health struggles, found dead</a></h3></div></li><li><a href="/us/wisconsin-cant-force-religious-schools-to-shut-down-court-rules.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243495_a_130_72_593_223.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/us/wisconsin-cant-force-religious-schools-to-shut-down-court-rules.html">‘Major victory’: Wisconsin can’t force private, religious schools to shut down</a></h3></div></li><li><a href="/us/texas-hospital-to-remove-pastors-banner-amid-complaint.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243467_a_130_72_206_275.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/us/texas-hospital-to-remove-pastors-banner-amid-complaint.html">Texas hospital will remove pastor's banner, defends chaplain program after atheist group complains</a></h3></div></li><li><a href="/us/jury-imposes-500k-verdict-on-pastor-accused-of-rape.html"><img src="https://cdn.christianpost.com/files/cache/thumbnail/24/34/243464_a_130_72_363_226.jpg" width="130" height="72"/></a><div><h3 class="h4"><a class="link" href="/us/jury-imposes-500k-verdict-on-pastor-accused-of-rape.html">Jury imposes $500K verdict on pastor accused of rape after he refused to apologize to victim</a></h3></div></li></ul></section></div></div></div></div></main><footer class="site-footer" role="contentinfo"><div class="container"><div class="footer-logo-line"><div class="branding" ><a href="/" itemprop="url"><img src="https://cdn.christianpost.com/assets/img/logo.svg" alt="Go to Homepage" width="595" height="31"></a><p class="visually-hidden">The Christian Post</p></div><div class="tools"><a class="btn btn-xs btn-outline uppercase" href="/signup" target="_blank">Subscribe Now <span class="i-arrow"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><path d="M13 2l22 22-22 22" stroke="currentColor" fill="none"/></svg></span></span></a><a class="btn btn-xs btn-fill" href="/contact-us.html">We want to hear from you! <span class="i-arrow"><span class="i-container"><svg width="48" height="48" viewBox="0 0 48 48" xmlns="http://www.w3.org/2000/svg"><path d="M13 2l22 22-22 22" stroke="currentColor" fill="none"/></svg></span></span></a></div></div><nav role="navigation" aria-labelledby="footer-nav-heading"><h2 class="visually-hidden" id="footer-nav-heading">Overall Navigation</h2><div class="nav-layout"><div><h3>Main</h3><ul><li class=" "><a href="/business" class="link">Business</a></li><li class=" "><a href="/sports" class="link">Sports</a></li><li class=" "><a href="/education" class="link">Education</a></li><li class=" "><a href="/lifestyle" class="link">Lifestyle</a></li><li class=" "><a href="/shopping" class="link">Shopping</a></li><li class=" "><a href="/books" class="link">Books</a></li><li class=" "><a href="/church-resource" class="link">Church Resource</a></li><li class=" "><a href="https://video.christianpost.com/" class="link">Video</a></li><li class=" "><a href="/podcast" class="link">Christian Podcasts</a></li></ul></div><div><h3>SECTIONS</h3><ul><li class=" "><a href="/business" class="link">Business</a></li><li class=" "><a href="/sports" class="link">Sports</a></li><li class=" "><a href="/education" class="link">Education</a></li><li class=" "><a href="/lifestyle" class="link">Lifestyle</a></li><li class=" "><a href="/shopping" class="link">Shopping</a></li><li class=" "><a href="/books" class="link">Books</a></li><li class=" "><a href="/church-resource" class="link">Church Resource</a></li><li class=" "><a href="https://video.christianpost.com/" class="link">Video</a></li><li class=" "><a href="/podcast" class="link">Christian Podcasts</a></li><li><a href="/newsletter/daily-newsletter" class="link">Christian Newsletter</a></li></ul></div><div><h3>About Us</h3><ul><li><a class="link" href="/about-us.html">About Us</a></li><li><a class="link" href="/statement-of-faith.html" >Statement Of Faith</a></li><li><a class="link" href="/general-disclaimer.html" >General Disclaimer</a></li><li><a class="link" href="/permissions-policy.html">Permissions Policy</a></li><li><a class="link" href="/editorial-policy.html">Editorial Policy</a></li><li><a class="link" href="/terms-and-conditions-of-use.html">Terms Of Service</a></li><li><a class="link" href="/privacy-policy.html">Privacy Policy</a></li><li><a class="link" href="/general-disclaimer.html">Disclaimer</a></li><li><a class="link" href="/email-whitelisting.html">Email Whitelisting</a></li><li><a class="link" href="/jobs.html">Employment Opportunities</a></li></ul></div><div><h3>Stay Connected</h3><ul><li><a class="link" href="/signup">Sign Up</a></li><li><a class="link" href="/voice/signup">Submit an Article</a></li><li><a class="link" href="/contact-us.html">Contact Us</a></li><li><a class="link" href="mailto:ChristianPost@pinkston.co" target="_self">Media Contact</a></li><li><a class="link" href="/advertising.html" target="_blank">Advertise With Us</a></li><li><a class="link" href="/rss-feed.html">RSS Feed</a></li><li><a class="link" href="/archives.html">Archives</a></li><li><a class="link" href="/corrections.html">Corrections</a></li><li><a class="link" href="/faq.html">Commenting FAQ</a></li><li><a class="link" href="/community-guidelines.html">Community Guidelines</a></li></ul></div><div><h3>Follow Us</h3><ul><li><a class="facebook" href="https://www.facebook.com/ChristianPost.Intl" target="_blank"><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M94.626 144H73.012V90.057H55v-20.95h18.012V53.693c0-8.83 2.561-15.733 7.685-20.71C85.5 28.328 91.904 26 99.909 26c4.483 0 9.847.24 16.091.722v18.784h-11.287c-6.725 0-10.087 3.05-10.087 9.151v14.45h20.654l-2.642 20.95H94.626V144z" fill="currentColor"/></svg></span></span> Facebook</a></li><li><a class="twitter" href="https://twitter.com/ChristianPost" target="_blank"><span class="i-social"><span class="i-container"><svg width="170" height="170" viewBox="0 0 170 170" xmlns="http://www.w3.org/2000/svg"><path d="M146 47.753s-4.762 7.685-12.472 12.884C135.115 95.897 109.264 135 62.323 135 38.967 135 24 123.699 24 123.699s18.368 3.842 36.963-10.172c-18.822-1.13-23.357-17.404-23.357-17.404s5.216 1.356 11.338-.452c-21.089-5.198-20.182-24.863-20.182-24.863s5.216 3.165 11.338 3.165C21.052 59.28 32.39 40.52 32.39 40.52s17.235 24.185 51.703 26.22c-4.989-27.35 26.532-40.007 42.632-22.829 8.39-1.356 16.1-6.103 16.1-6.103s-2.72 9.267-11.111 13.788c6.803-.452 14.286-3.843 14.286-3.843z" fill="currentColor"/></svg></span></span> Twitter</a></li><li><a class="instagram" href="https://www.instagram.com/christianpostintl" target="_blank"><span class="i-social"><span class="i-container"><svg width="32" height="32" viewBox="0 0 800 800" xmlns="http://www.w3.org/2000/svg"><path fill="currentColor" d="M150 400c0-119 0-166 42-208s88-42 208-42 166 0 208 42 42 89 42 208 0 166-42 208-88 42-208 42-166 0-208-42-42-89-42-208zm455 0c0-114 0-148-29-176-29-29-62-29-176-29s-148 0-176 29c-29 29-29 62-29 176s0 148 29 176c29 29 62 29 176 29s148 0 176-29c29-29 29-62 29-176zM400 272a128 128 0 1 1 0 256 128 128 0 0 1 0-256zm0 211c46 0 83-37 83-83s-37-83-83-83-83 37-83 83 37 83 83 83zm163-216c0 16-13 30-30 30-16 0-30-14-30-30 0-17 14-30 30-30 17 0 30 13 30 30z"></path></svg></span></span>Instagram</a></li></ul></div></div></nav><div class="copyright"> &nbsp; <span itemprop="copyrightYear">2021</span><span itemprop="copyrightHolder provider sourceOrganization" itemscope itemtype="http://schema.org/Organization" itemid="https://www.christianpost.com"><span itemprop="name">The Christian Post, INC</span></span>. All Rights Reserved. </div></div></footer><div id="g_id_onload"></div> <script type="text/javascript" src="https://cdn.christianpost.com/assets/js/script.js"></script> <script type="text/javascript" src="https://cdn.christianpost.com/assets/js.js"></script> <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"e8fd0ff4b9","applicationID":"205435291","transactionName":"MgRbbEsCDUNUUkwLXAtObEpQTExGVEMXFUQSTlpQSwoQRFxQVhJcFhUXW1YOTEBAU1QLUDoJTVVVTBNFV11RARwMD11dQU0TWEU=","queueTime":0,"applicationTime":201,"atts":"HkNYGgMYHk0=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body></html>